I happened to be looking at an old CDF (19 months old). It previously worked and does not now. It works if downloaded (opening or at URL). It requires dynamic functionality to be enabled but no longer prompts. I am uncertain how to resolve this.

I apologise in advance if this is a duplicate and await redirection.

  • $\begingroup$ Thank you @Nasser. Have tried in Chrome, Torch and now Firefox browsers still does not let me enter text in InputField. $\endgroup$
    – ubpdqn
    Aug 3, 2013 at 9:20
  • $\begingroup$ @Nasser thanks for the prompt response. I had tried to simplify the scripting with no success but will try your suggestion. $\endgroup$
    – ubpdqn
    Aug 3, 2013 at 9:31
  • $\begingroup$ Your simplified script runs the player but I still cannot type into field. Thanks for link @Nasser. I do not want to waste anybodoes time on a trivial matter. $\endgroup$
    – ubpdqn
    Aug 3, 2013 at 9:36

1 Answer 1


The CDF file contains InputField[__, String, ____] which I've seen through notepad.

Only numeric InputFields are going to work in FreeCDF:

CDF, Player Pro, and Mathematica Features Comparison Chart

It works if you download it because it automatically opens in Mathematica if you have it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.