7
$\begingroup$

I am working on a notebook of size 5 MB which contains only data and Plot or ListPlot on WIN64 with MMA13.3.

I am experiencing issues with this Mathematica notebook where it begins formatting content automatically by showing a dialog saying "Formatting Notebook Contents", taking a long time, and then collapsing, see screenshot below.

enter image description here

Working with MMA12.3 on the same notebook, such a thing never happened.

$\endgroup$
5
  • 1
    $\begingroup$ It's hard to test without the code. What is new in v13 and affects the performance is PlotHighlighting. Try using Plot[ ..., PlotHighlighting -> None]. $\endgroup$
    – Domen
    Jan 10 at 10:08
  • 2
    $\begingroup$ I may have had this problem too. I believe it's related to the dynamic callout things they added where you can put the mouse on points or lines in the plot and it will show the value as you scrub over it. Try disabling ''Dynamic Updating Enabled' from the Evaluation menu. Also if you don't want to do that, try adding PlotHighlighting -> None to your plots to get rid of the callouts as Domen already mentioned. $\endgroup$
    – flinty
    Jan 10 at 11:11
  • $\begingroup$ @Domen, PlotHighlighting -> None magically works, I have working now for 1 hour and everything is fine before it happens every few minutes. $\endgroup$
    – MMA13
    Jan 10 at 11:37
  • $\begingroup$ @flinty, is it possible to make the default PlotHighlighting -> None without adding in each plot? $\endgroup$
    – MMA13
    Jan 10 at 11:39
  • 1
    $\begingroup$ Yes, it is possible: SetOptions[Plot, PlotHighlighting -> None]; I guess this question could deserve an answer, since it might be happening often for users coming to v13. $\endgroup$
    – Domen
    Jan 10 at 11:53

1 Answer 1

10
$\begingroup$

The reason you see a significant slowdown is the introduction of PlotHighlighting in version 13.3, which is turned on by default and controls the appearance of highlighting features of plots when you mouse hover over them.

You can turn it off by using PlotHighlighting -> None inside your *Plot functions. To disable it generally, use SetOptions:

SetOptions[Plot, PlotHighlighting -> None];
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.