Bug introduced in 9.0 and fixed in 9.0.1

I have a problem with the Check Spelling in Mathematica, that I quite don't understand:

If I try to use the Check Spelling on any notebook, the check just stop before the first word and in the field "Reason for stopping:" is written: "The spelling dictionary file Mathematica.rws could not be loaded. The file may be corrupted."

I found nothing about this on the Internet, but after a research on my computer I found that this file is at "/usr/local/Wolfram/Mathematica/9.0/SystemFiles/SpellingDictionaries/English/Mathematica.rws" (I'm on Linux)

There is also another directory called SpellingDictionaries at ~/.Mathematica/SystemFiles/SpellingDictionaries, but it is empty.

I tried by copying the content of the first directory in the second, but it doesn't work.

I also tried to use another file Mathematica.rws that I found in /WINDOWS/Program Files/Wolfram Research/Mathematica/8.0/SystemFiles/SpellingDictionaries on another computer (under Windows) that had Mathematica V8 (with which the check spelling worked). I doesn't work either.

Can anyone help me ? I would really like to be able to use Mathematica to write my report.

  • 1
    $\begingroup$ Could you try restoring to factory settings and let us know if it helped? $\endgroup$ Jul 30, 2013 at 21:51
  • $\begingroup$ Doesn't worked... I'll try to update to 9.0.1 $\endgroup$
    – user7987
    Jul 31, 2013 at 14:23
  • $\begingroup$ user, you don't need the "[Solved]" tag in the title; that's what the Accept feature is for, which I see you already know how to use (thanks). $\endgroup$
    – Mr.Wizard
    Jul 31, 2013 at 19:37

1 Answer 1


I do not recall all the details, but I belive this was a bug on some operating systems (e.g. Linux x86) for$Version 9.0 $ReleaseNumber 0. It should be fixed if you upgrade to 9.0.1. Let me know if that fixes your problem.

  • $\begingroup$ The update to 9.0.1 solved the problem. Thanks! $\endgroup$
    – user7987
    Jul 31, 2013 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.