0
$\begingroup$

I've looked for a solution, but couldn't find one. I've reinstalled,but still get the following two (related) messages on startup:

The specified setting for the option GridCreationSettings, Columns cannot be used

and

An option ("GridCreationSettingsColumns->Round[Null]") was encountered with a right‐hand side value out of the supported range for this option.

Thanks in advance for any solution(s).

$\endgroup$
8
  • $\begingroup$ Welcome to Mathematica.SE! I hope you will become a regular contributor. To get started, 1) take the introductory tour now, 2) when you see good questions and answers, vote them up by clicking the gray triangles, because the credibility of the system is based on the reputation gained by users sharing their knowledge, $\endgroup$
    – Dunlop
    Commented Aug 5, 2023 at 1:26
  • $\begingroup$ 3) remember to accept the answer, if any, that solves your problem, by clicking the checkmark sign, and 4) give help too, by answering questions in your areas of expertise. $\endgroup$
    – Dunlop
    Commented Aug 5, 2023 at 1:27
  • 1
    $\begingroup$ Please give some more information (OS, version of Mathematica). It could be that this question can only be answered by Wolfram Research if this is a software issue in which case the question risks being closed. $\endgroup$
    – Dunlop
    Commented Aug 5, 2023 at 1:28
  • $\begingroup$ Anything in your init.m file? Relevant, I suppose: reference.wolfram.com/language/ref/GridCreationSettings.html. There is no symbol GridCreationSettingsColumns in Mma. Is there a typo in the question? $\endgroup$
    – Michael E2
    Commented Aug 5, 2023 at 3:01
  • $\begingroup$ So far I'm really only using the software for presentation/notes creating... I'm really just clicking "Insert slide", or "Add cell" or changing cell types, or adding a table for side by side layouts. I don't think i've tried to manually adjust any settings. Re possible typos in question, I copied the text direct from the error messages. $\endgroup$ Commented Aug 5, 2023 at 4:37

1 Answer 1

1
$\begingroup$

I had this problem as well. I first saw it on Mathematica 12.3.1 after running that for a few years. It persisted when I upgraded to 14.0.

Following the suggestion by user87932 in the comments above, I renamed all the init.m files in ~/Library/Mathematica/ . I restarted Mathematica and it had me sign in at the Wolfram Portal. Then it worked fine. The init.m files are back.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.