I loaded the new MMA 13.3 and tried following https://writings.stephenwolfram.com/2023/06/llm-tech-and-a-lot-more-version-13-3-of-wolfram-language-and-mathematica/

The website states "The most immediately visible LLM tech in Version 13.3 is Chat Notebooks. Go to File > New > Chat-Enabled Notebook and you’ll get a Chat Notebook".

When I try that, I receive the following

enter image description here

Any ideas on what I am missing?

I am running Windows 10 on an x86 processor.


  1. From the Comment regarding manually loading - I cannot manually load because the notebook gets hung up immediately and will not go passed that error message (the NB is effectively hung).

The output (after some time) was enter image description here

  1. Here is a workaround that worked, but I am not sure how or why.

-- I opened a Chat-Driven Notebook instead of a Chat-Enabled Notebook.

-- I entered my OpenAI token, and a command and it worked (this is the general LLM with OpenAI and not the MMA variant).

-- After the previous step, I opened a Chat-Enabled Notebook and now it worked and is using MMA for code (I wonder if it is because I was able to enter the OpenAI Token from the previous step).

Maybe there needs to be a note to enter an OpenAI Token from your OpenAI account to get these Chat NBs to work.

Update 2 The above did not work on my home computer, but the following did.

  1. Open a regular Mathematica Notebook.

  2. Paste PacletInstall["Wolfram/Chatbook" -> "1.0.0", UpdatePacletSites -> True]

  3. Now try opening a chat-enabled ot chat-driven session and mine worked.

  • 1
    $\begingroup$ Have you tried to install the paclet manually? PacletInstall["Wolfram/Chatbook"->"1.0.0", UpdatePacletSites->True] $\endgroup$
    – Lacia
    Commented Jun 29, 2023 at 18:02
  • $\begingroup$ @Lacia: That did not work, but I messed around with it and figured out a convoluted workaround. See my update to the question. Thanks! $\endgroup$
    – Moo
    Commented Jun 29, 2023 at 19:36
  • $\begingroup$ Moo: How did you enter you Open AI token? -- I entered my OpenAI token, and a command and it worked (this is the general LLM with OpenAI and not the MMA variant). $\endgroup$
    – user23438
    Commented Jun 29, 2023 at 23:51
  • $\begingroup$ After trying to do a call to Chat-Driven Notebook, it asked for the Token and I had to go to the Open AI site, get an account, generate a token and cut and paste it into the MMA window asking for it. This only needs to be done onec. $\endgroup$
    – Moo
    Commented Jun 30, 2023 at 0:24
  • $\begingroup$ Also see my second update in my question. $\endgroup$
    – Moo
    Commented Jun 30, 2023 at 1:12

1 Answer 1


Besides inputting the OpenAI API key, you need to setup billing details and add some amount to your OpenAI account in order to get the LLM functionality working in Mathematica. Otherwise you will get the "exceeded quota" error message.

Go to platform.openai.com/apps → “API”. Click on the top right buttom displaying your initial (where is says “personal”) → click “manage account” → “billing” → “payment methods” → “add payment methods”. Add your credit card. It will ask you to add some funds to the account. Start with 5 dollars.

That’s it. After adding some money, wait a few minutes and try again Mathematica’s LLM funcionality. It should work now.

Detailed instructions here.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.