2
$\begingroup$

i was working some huge matrices in the context of FEM, so sometimes it seems they were too big and the kernel crashed. Normally that isn't a problem, but after one time i couldn't connect to the subkernels.

The exact error message after LaunchKernels[] is:

LinkObject: "Unable to communicate with closed link 
LinkObject[\!\(\"\\\"C:\\\\Program Files\\\\Wolfram 
Research\\\\Mathematica\\\\13.2_2\\\\WolframKernel\\\" -noinit 
-noicon -subkernel -wstp\"\),295,11]"

Parallel`Developer`ConnectKernel: 4 of 4 kernels failed to initialize.

Well sometimes i can connect to 3 random subkernels. I also tried to connect a new kernel to a remote cluster a few hours before the error occured, the kernel didn't do anything, so i just closed it again. But maybe that could be a reason for this error. The error messages are shown in a picture below. I already tried reinstalling mathematica in versions 12.2 and 13.2 and searched for this error, but nothing seems to come up. So i would appreciate if someone could help decipher what is happening. Cheers The error messages after trying to Launch the kernels and also the currently open links after trying to launch the kernels

$\endgroup$
2
  • 1
    $\begingroup$ From the code given I can not reproduce this. Unless there is a way to reproduce this is hard to investigate. Can you provide code to reproduce it? $\endgroup$
    – user21
    May 1, 2023 at 4:53
  • $\begingroup$ @user21 Thank you for your reply. But the problem was, that the error was not code-dependent. But I've found out that it seems to be a problem with the license-server my workplace is using and the process limit is reached by some frozen processes. So I will try to restart MathLM and hope it works after that. :) $\endgroup$
    – cmh99
    May 2, 2023 at 6:44

1 Answer 1

4
$\begingroup$

So in case anyone else has the same problem in the future. It seems that it was a problem with the license-server of my workplace, which only allows a certain number of processes at the same time. There were some frozen processes which filled up the list until no processes were available.

So the solution for me was to contact my system administrator (or in your case whoever is running the MathLM-Server) ane either letting him reboot MathLM or firstly letting him look at the MonitorLM functionality the check if that is the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.