I am experiencing a puzzling behaviour when trying to use the font Fontin in Mathematica

If I attempt to use the regular variant of the font, Mathematica instead displays the small caps variant. However, if I use bold or italics, Mathematica displays the font correctly. If I use the small caps variant is also displays correctly.

This happens both if I manually style some text going through the menu 'Format' -> 'Font...', and also if I style using code. E.g.

Style["Some text", FontFamily -> "Fontin", FontWeight -> Plain]

Displays as small caps:

screenshot of small caps


Style["Some text", FontFamily -> "Fontin", FontWeight -> "Bold"]

Displays correctly:

screenshot of bold

Why is Mathematica mapping the plain variant of this font to the small caps variant?

I am working on Ubuntu and Fontin works fine in other applications on the system.

  • $\begingroup$ With "12.1.1 for Mac OS X x86 (64-bit) (June 19, 2020)" , the font works as expected. $\endgroup$
    – Bob Hanlon
    Apr 14, 2023 at 23:25
  • $\begingroup$ If I export to pdf, the font is displayed correctly in the pdf-viewer, so it is only the display within Mathematica itself which is failing apparently $\endgroup$
    – JonatanBB
    Apr 14, 2023 at 23:27
  • $\begingroup$ Welcome to the Mathematica Stack Exchange. Was this font previously working correctly? Do other fonts have any altered behavior? Did you try reinstalling the font? Is this font behaving as it should in other applications? Did you try restarting Mathematica? $\endgroup$
    – Syed
    Apr 15, 2023 at 2:51

1 Answer 1


Look at Preferences and search for "Font". There is a long search string where to look for Font families. In Windows "Fontin" is not in the pulldown selection menu of font families, nevertheless FontFamily-> "Fontin" produces output by a default font substitution rule.

  • $\begingroup$ Trying the "Fontin" in Ubuntu Studio 22,04. Its not present. The Output is rendered in the Default Font defined in the Style sheet for Output Cells. $\endgroup$
    – Roland F
    Apr 19, 2023 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.