I'm trying to get the same plot as Figure 10.1.1 in Mathematica.

enter image description here

I tried using the command

VectorPlot[{1 - (x^2 - y^2)/(x^2 + y^2)^2 , -2 (x*y)/(x^2 + y^2)^2 },
  {x, -10, 10}, {y, -10, 10}]  

but I don't know what I'm doing wrong. How can I get the plot?

enter image description here

I attach an image of that with another curve if it works well.

enter image description here

  • $\begingroup$ Using your code, I get the correct plot. Which version of Mathematica are you using? You can find out by evaluating $Version. Also, can you please try with a fresh kernel? That is: Use Quit[], and then try to plot the field again. $\endgroup$
    – Domen
    Mar 11 at 15:26
  • $\begingroup$ "12.0.0 for Microsoft Windows (64-bit) (April 6, 2019)" $\endgroup$
    – eraldcoil
    Mar 11 at 15:29
  • $\begingroup$ still not working $\endgroup$
    – eraldcoil
    Mar 11 at 15:35
  • $\begingroup$ What if you try to plot examples from the documentation, like VectorPlot[{y, -x}, {x, -3, 3}, {y, -3, 3}]? Do they work? $\endgroup$
    – Domen
    Mar 11 at 15:40
  • 3
    $\begingroup$ I’m voting to close this question because the poster has resolved the issue $\endgroup$
    – Bob Hanlon
    Mar 11 at 20:51


Browse other questions tagged or ask your own question.