2
$\begingroup$

Normally, when reevaluating a cell, the following output cell is overwritten with the new result. I have a lengthy notebook in which at some point for unknown reasons each reevaluation generates a new output cell. I have no clue how to stop this - I think it has to do with the option OutputAutoOverwrite, but setting this to True does not help. Any clue on how to reset the behaviour of the notebook to the default?

After experimenting more the situation gets even worse: If I set both CellAutoOverwrite and OutputAutoOverwrite to True, reevaluating expressions overwrite now the following output cell. But if there is a text cell following the output cell, the text cell gets overwritten with the revised output cell! And if there is a subsection cell following the output cell, the output cell is deleted, but the new output cell is placed after the subsection cell...

Found the reason now for this strange behaviour: All text cells and subtitle cells had received the option CellAutoOverwrite->True. By manually changing this to False (but leaving OutputAutoOverwrite to True), the notebook behaves now again normally.

$\endgroup$
  • $\begingroup$ Sometimes I noticed what you've said. But a concrete example would be more welcome. $\endgroup$ – HyperGroups Jun 27 '13 at 13:17
  • $\begingroup$ Where do I change these parameter settings? $\endgroup$ – JohnD Aug 19 '13 at 20:55
1
$\begingroup$

OP found the answer but didn't post it:

Found the reason now for this strange behaviour: All text cells and subtitle cells had received the option CellAutoOverwrite->True. By manually changing this to False (but leaving OutputAutoOverwrite to True), the notebook behaves now again normally.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.