7
$\begingroup$

enter image description here

It was working perhaps until a week ago. Now it gets stuck on similar invocations with no apparent activity. The only way out is a kernel restart. Alt+. does not work.

  1. I am using v12.2.0 on Win7-x64.

  2. Previously downloaded resource functions are still usable.

  3. Entity system is functional.

What could be wrong and how can this be fixed? When using a resource function that has not been downloaded yet, does the software download other unrequested but mandatory paclets etc? Could it be holding up the process?

EDIT2

While trying (among) other things such as TestInternetConnectivity from the Preferences, the following error shows up:

enter image description here

URLFetch::ssl : An SSL error occurred . The raw details are :
"libcurl error (35): schannel: next InitializeSecurityContext
failed: SEC_E_ILLEGAL_MESSAGE (0x80090326) - This error usually
occurs when a fatal SSL/TLS alert is received (e.g. handshake
failed). "

Google search reveals that many users have recently been getting the same error message while using other programs. Perhaps it is a browser setup issue or the server implementing more security protocols now for which my windows machine is not set up.


Thanks for your help.

$\endgroup$
5
  • $\begingroup$ FWIW, it works on 13.1 on Mac OS Big Sur. $\endgroup$
    – Victor K.
    Nov 30, 2022 at 17:42
  • $\begingroup$ Works on MMA 13.1 Windows 10 $\endgroup$ Nov 30, 2022 at 19:16
  • $\begingroup$ Thank you both. As I mentioned, it was working on v12.2.0 a week ago. I am thinking that some file or directory got corrupted and I am looking for a standard procedure/workaround to reset this functionality etc. $\endgroup$
    – Syed
    Dec 1, 2022 at 2:08
  • $\begingroup$ I've got the same problem and afraid that real problem is in Windows 7. On 10 all work. But I like my notebook with Win 7 so hope someone can help $\endgroup$
    – lesobrod
    Dec 17, 2022 at 17:20
  • $\begingroup$ Maybe download the source notebook (from the button at the top right) and install it as a package manually. I had trouble with the resource function AntiSimplify (although i believe a different one) and did that if I remember well. $\endgroup$ Dec 17, 2022 at 21:56

1 Answer 1

2
$\begingroup$

So I'm afraid that the problem is in Win 7. But I would like to continue using this OS on one of the laptops.
Therefore, I found a working solution - download all the necessary functions on the device where it's possible, and create a local paclet, as described here.

$\endgroup$
2
  • 1
    $\begingroup$ Thanks for your help. I will look at this further. I have been downloading and using these, but this pacletizaton would improve the procedure and make it more convenient. $\endgroup$
    – Syed
    Dec 17, 2022 at 18:01
  • 1
    $\begingroup$ May I ask if you have been able to isolate the problem and why it started less than a month ago? $\endgroup$
    – Syed
    Dec 17, 2022 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.