4
$\begingroup$

I have a number of notebooks written for whatever the current version was of Mathematica in 2019 (not 1919 as I had earlier) and using the ccgrg package for general relativity. They now no longer work. There is no error, but the key functions such as tRicciR[a,b] that should give something like

tRicciR[1, 1]

(* (2 α λ + x^2 β^2 λ^2 + y^2 β^2 λ^2 + 4 z^2 β^2 λ^2 - *********** *)

but just return tRicciR[a,b] rather than evaluating the function. Is this a known problem? And If there is no way to get ccgrg to run in 12, is there a way to resurrect the 2019 version of Mathematica? I've lost a lot of work if it is a dead package

Here is the outpout that fails at the first ccgrg call:

enter image description here

$\endgroup$
6
  • 3
    $\begingroup$ Did Mathematica of 1919 work with a slide rule? $\endgroup$ Feb 28 at 17:49
  • $\begingroup$ Ooops. I am stil stuck in the last century it seems. Edited. $\endgroup$
    – mike stone
    Feb 28 at 17:58
  • $\begingroup$ Crossposted here. $\endgroup$ Feb 28 at 20:29
  • $\begingroup$ Link related to the package: library.wolfram.com/infocenter/MathSource/8848 $\endgroup$
    – kcr
    Feb 28 at 21:20
  • $\begingroup$ there are alternatives if you want to code curvature tensors. a package is not required. there are good, thorough answers on this site as well. $\endgroup$
    – kcr
    Feb 28 at 21:44

2 Answers 2

6
$\begingroup$

We talked to Andrzej Woszczyna who is part of the ccgrg team. He was still using an old version of Mathematica and did not know of the problem. It turns out that Mathematica broke several things when upgrading beyond Mathematica 12.2. These can be fixed by including the lines

If[$VersionNumber >= 12.2,
   SetOptions[ValueQ, Method -> "Legacy"];
   SetOptions[Solve, Assumptions -> {}]];

before the Needs["ccgrg`"] command.

$\endgroup$
1
  • 2
    $\begingroup$ I think it's better to accept this answer instead. (It's perfectly OK to accept your own answer. ) $\endgroup$
    – xzczd
    Jun 20 at 16:08
2
$\begingroup$

It worked for me. See the following, please:

pic

$\endgroup$
3
  • $\begingroup$ Thanks. I wonder if I've screwed up. I did re-download and reinstall the version from the Mathematica site, but still not doing what I expect. $\endgroup$
    – mike stone
    Feb 28 at 21:41
  • $\begingroup$ @mikestone what I did is the following: unzipped the file, and then opened the assistant.nb and followed precisely the instruction that was given there, i.e copy and paste ccgrg.m on the right path. if you think this answer is helpful, consider accepting it by clicking on the checkmark sign $\endgroup$
    – kcr
    Feb 28 at 21:43
  • $\begingroup$ @ckr I got back to this, and ccopied your file exactly. When I ran it it aborted at the first ccgrg command. I've added rthe output to my original question. $\endgroup$
    – mike stone
    Mar 7 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.