2
$\begingroup$

With Mathematica 12.31 and 13 on Windows 10 when executing any command with GeoGraphics gives the error: URLFetch::invhttp: A library error occurred. The raw details are: "libcurl error (28): Operation timed out after 10001 milliseconds with 0 bytes received"

Is this only on my system?

GeoGraphics[]
$\endgroup$
11
  • 3
    $\begingroup$ This also works fine for me. Have you tried using a different GeoServer? Try something like GeoGraphics[GeoServer -> "http://a.tile.openstreetmap.org/`1`/`2`/`3`.png"]. It's possible that the Wolfram tileserver is on the blink or that something is blocking the requests. $\endgroup$
    – Carl Lange
    Dec 21, 2021 at 16:25
  • $\begingroup$ @CarlLange hmm.. that seems to work. $\endgroup$
    – Lou
    Dec 21, 2021 at 16:27
  • 3
    $\begingroup$ In that case it seems likely that something is causing your requests to the Wolfram tileserver to stop working. See if geo.wolfram.com might be blocked on your network (it will give Forbidden if you go to it in a browser). $\endgroup$
    – Carl Lange
    Dec 21, 2021 at 16:39
  • 3
    $\begingroup$ @david I believe GeoIdentify uses an implementation of OpenStreetMaps' Nominatim service that runs on Wolfram's infrastructure. Depending on what you need, you may be able to query a different instance of that service. This Q&A of mine may also be of interest: mathematica.stackexchange.com/questions/195482/… You could also stand up an instance of Nominatim yourself, or an instance of PostGIS, which also has some geocoding built-in (iirc). $\endgroup$
    – Carl Lange
    Dec 21, 2021 at 22:41
  • 2
    $\begingroup$ @CarlLange And 10 minutes later it suddenly worked. Perhaps threatening with logging a case made the difference? $\endgroup$
    – Lou
    Dec 22, 2021 at 8:34

0

Browse other questions tagged or ask your own question.