4
$\begingroup$

I have always used the Ctrl+. keyboard shortcut (ExpandSelection) to select a group of text. Repeatedly pressing . (whilst still holding Ctrl) would select a growing area of text, up until the entire cell has been selected. Recently, I noticed that this shortcut does not behave as expected for me anymore. The sequence Ctrl+.+. makes a small letter 'e' appear in the top left corner, where any subsequent is entered. This seems to be some edit window that can be escaped with Enter, which enters the text at the current cursor position.

For example, here I typed: Sin[x], then Ctrl+.+. (the 'e' window appears), Cos and finally Enter to escape that window and insert the text.

enter image description here

Can anyone explain this behaviour? I looked into my KeyEventTranslations.tr file and still have the expected line: Item[KeyEvent[".", Modifiers -> {Control}], "ExpandSelection"],

I checked this behaviour in versions 12.3 and 13.0. I'm running Fedora 35 x86_64.

$\endgroup$
4
  • $\begingroup$ I would report this, it certainly seems like a bug $\endgroup$
    – Jason B.
    Dec 20, 2021 at 13:18
  • 1
    $\begingroup$ I do not reproduce this behavior with versions 12.3.1 and 13.0 on Windows 10 x64. I do not get the 'e' window. $\endgroup$ Dec 20, 2021 at 13:46
  • 4
    $\begingroup$ That looks like you've managed to trigger your platform's Input Method Editor (IME). $\endgroup$
    – ihojnicki
    Dec 20, 2021 at 15:28
  • $\begingroup$ Yes, I think it's a Linux specific issue. The problem must have appeared recently after a Linux kernel update. $\endgroup$
    – dzejkob
    Dec 20, 2021 at 15:35

2 Answers 2

7
$\begingroup$

Solved it. In case someone runs into the same issue in the future, I'll describe here what I've done.

By typing Ctrl+. in Gedit, I found out this shortcut launches the emoji input menu (thanks to @ihojnicki for pointing out in the comments that what I was doing is launching an IME). Then, I followed this post to find out how to change that keybinding since it was not available under the standard Settings->Keyboard->Keyboard Shortcuts in Gnome.

I had to install dconf-editor instead. From there, I navigated to /desktop/ibus/panel/emoji/hotkey and had to change the keybinding from Ctrl+. to something else. Saved the changes, reloaded Mathematica, done.

$\endgroup$
0
$\begingroup$

Having the same problem with an upgrade from Ubuntu 20.04 to 22.04, I searched a bit and found a way to disable these emoji-editor shortcuts Ctrl-. and Ctrl-;. I used a variant of what they propose, running the following command in a terminal. This leaves the emoji editor available as Ctrl-Shift-e.

gsettings set org.freedesktop.ibus.panel.emoji hotkey "['<Control><Shift>e']"
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.