0
$\begingroup$

I am trying to compute the following system of differential equations:

DSolve[
{
x'[t]==x[t] (2+2 x[t]^2-y[t]^2-y[t] (2+z[t])+x[t] (-4+y[t]+z[t])),
y'[t]==-y[t] (1-2 x[t]^2+y[t]^2+y[t] (-2+z[t])-x[t] (y[t]+z[t]))
}, {x[t],y[t],z[t]},t]

And it's not working. It's not clear why, it says:

DSolve::dvnoarg: The function x appears with no arguments.

Trying the following example to find what I typed wrong:

enter image description here

And then, I tried:

DSolve[{y'[x] == x^2 y[x], z'[x] == 5 z[x]}, {y, z}, x]

DSolve[{y'[x] == x^2 y[x], z'[x] == 5 z[x]}, {y[x], z[x]}, x]

But it gave the same error:

DSolve::dvnoarg: The function y appears with no arguments.

It's not clear what's happening.

$\endgroup$
3
  • 1
    $\begingroup$ you have more dependent variables than odes. $\endgroup$
    – Nasser
    Dec 19 '21 at 5:18
  • $\begingroup$ @Nasser But what is happening in the example I mentioned? In the Mathematica help file, it is computed but I can't compute it. $\endgroup$
    – Red Banana
    Dec 19 '21 at 5:28
  • 3
    $\begingroup$ Your first example does not work. The rest works. Start with clean kernel and run your first example again, you should get an error There are more dependent variables than equations, so the system is underdetermined Look carefully at your equations. You only have two equations but three dependent variables specified. x[t],y[t],z[t]. I do know why you get The function x appears with no arguments.. If you start with clean kernel this should not be the error. $\endgroup$
    – Nasser
    Dec 19 '21 at 5:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.