13
$\begingroup$

In Mathematica 13 the font and everything else in notebooks and the size of toolbars is too big, compared to Mathematica 12.3 (with all the settings the same, magnification set at 100%).

It seems, the "global magnification" setting actually works (for the purpose of correcting everything being big), but does not affect the palettes (but per-palette magnification setting is remembered, so not a big problem), does not affect the about and welcome dialogs, and does not affect some elements in the notebook windows (the "+" at the top of the notebook and the cell braces at the right). Here is Mathematica 13 with global magnification 75%:

enter image description here

Here is Mathematica 12.3 with global magnification 100%, the font size is the same, but the "+" and braces are smaller:

enter image description here

The welcome screen, about dialog, etc, still remain too big, because global magnification does not affect them.

It reports scale 1.3333...: enter image description here

$\endgroup$
16
  • 3
    $\begingroup$ fyi, I also noticed this first time I installed V13. It is also discussed in community wolfram. $\endgroup$
    – Nasser
    Dec 20, 2021 at 6:39
  • 3
    $\begingroup$ I do not know if this can be called a "bug" or not in traditional sense. But it certainly annoying. But many have noticed this and complaining about it. May be you could submit a request to support and see what they say about it? $\endgroup$
    – Nasser
    Dec 20, 2021 at 6:51
  • 4
    $\begingroup$ It's not a bug. The appearance now matches the documented behavior of WindowSize, ImageSize, etc... More specifically, the Windows and Linux frontend in v13 no longer misrepresent the dpi of the display under any circumstance. In this case 12.3 would have reported 72 for CurrentValue["WindowResolution"], instead of the 96 that Windows uses. $\endgroup$
    – ihojnicki
    Dec 20, 2021 at 15:19
  • 2
    $\begingroup$ It means that WindowSize and ImageSize are not in pixels. i.e., WindowSize->{100, 100} is actually 133.333x133.333 pixels across on a 96dpi display. If you had a 4k display running at 175% then it would be 233.333x233.333 pixels. $\endgroup$
    – ihojnicki
    Dec 20, 2021 at 15:42
  • 5
    $\begingroup$ You can revert back to the legacy behavior by evaluating the following, CurrentValue[$FrontEnd, "ScreenResolutionCompatibilityMode"] = True and restarting the FrontEnd. This only works if all of your displays are set to 100% under the display settings in the Settings app. I make no guarantees that this will continue to work in future versions. $\endgroup$
    – ihojnicki
    Dec 20, 2021 at 15:45

2 Answers 2

4
$\begingroup$

Following the advice by ihojnicki, evaluating

CurrentValue[$FrontEnd, "ScreenResolutionCompatibilityMode"] = True

brings everything back to normal. The lines are again 1px wide, not 1.333 px. The "scale" in system properties became 1.x.

enter image description here

Note however that

This only works if all of your displays are set to 100% under the display settings in the Settings app. I make no guarantees that this will continue to work in future versions.

So this method works only if all of your displays are set to 100% under the "Display" in the Windows "Settings" application:

screenshot

And of course, there is no guarantee that this will continue to work in future Mathematica versions.

More information from Ian Hojnicki:

12.1.0 - 12.3.1 has an active compatibility shim which forces 96dpi displays to report as if they were 72dpi. Evaluating the following will disable it, but I would restart the FrontEnd afterwards.

CurrentValue[$FrontEnd, "ScreenResolutionCompatibilityMode"] = False

So the undocumented option "ScreenResolutionCompatibilityMode" simply switches on and off the compatibility shim.

$\endgroup$
1
  • 1
    $\begingroup$ Any ways to resolve this issue if I still want 125% scale in Windows? $\endgroup$ May 28 at 21:41
3
$\begingroup$

There is another workaround, which doesn't affect cell braces but fixes the low-quality rendering of Images in the FrontEnd of version 13.0.0 (Image appears as GraphicsBox inside of a Notebook):

SetOptions[$FrontEnd, GraphicsBoxOptions -> {BaseStyle -> Magnification -> 72/96}]

This affects all Image and Graphics objects in all Notebooks.

For reverting to the defaults one should evaluate:

SetOptions[$FrontEnd, GraphicsBoxOptions -> {BaseStyle -> Inherited}]

Strongly related Wolfram Community thread:

$\endgroup$
2
  • $\begingroup$ This is even worse than setting global magnification. $\endgroup$
    – Anixx
    Feb 19 at 21:25
  • $\begingroup$ As you can see from the question, the only problem was with the braces as global magnification fixes everything else. $\endgroup$
    – Anixx
    Feb 19 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.