2
$\begingroup$

I am trying to work in an HPC cluster. Mathematica works fine and I can export tables that I need. However, I had one interpolated data saved in as a mx file. I tried to import it, but it gives me some error as this:

DumpGet::bgmx: File /home/someuser/research/Mathematica/trial/file.mx
 does not appear to be a binary file or is corrupted.

This import works totally fine in my PC but the problem is just with the cluster. Would you please help me how to fix the issue?

$\endgroup$
5
  • 3
    $\begingroup$ mx files are system dependent, they do not often transfer between systems very well, if at all. (There are exceptions, however!) $\endgroup$ Sep 21, 2021 at 17:31
  • 1
    $\begingroup$ Use Save / Get instead of DumpSave / DumpGet. The former are platform independent. $\endgroup$ Sep 21, 2021 at 19:56
  • 1
    $\begingroup$ alternatively, .wxf format is compact, platform independent and fast (not as fast as mx though). $\endgroup$ Sep 22, 2021 at 11:11
  • 1
    $\begingroup$ @PavelPerikov Thank you wxf worked $\endgroup$
    – Rupesh
    Sep 22, 2021 at 17:07
  • $\begingroup$ @RohitNamjoshi Get didn't work but changing the format to wxf worked though. Thank you $\endgroup$
    – Rupesh
    Sep 22, 2021 at 17:08

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.