0
$\begingroup$

Mathematica 9.0.1, Linux. I try to save a plot as a pdf. I tried four different options. In each case some errors appeared as blank space

image 1

( http://yadi.sk/d/h1koyDci4z3rc ). I also tried to save as eps. Another problem appeared -- there is no half letter on the Labels:

image 2

(see here http://yadi.sk/d/OBRDmp3z4z42U ). The same figures are saved very well in Mathematica 7 without an error. Is it possible to solve this problem?

$\endgroup$
11
  • $\begingroup$ Convert to bmp and png works well, without errors. $\endgroup$
    – nail
    Commented May 19, 2013 at 18:13
  • 2
    $\begingroup$ I've added your images. Could you please include the code to reproduce the plots? See the help page for how to format code. $\endgroup$
    – Jens
    Commented May 19, 2013 at 18:30
  • $\begingroup$ The same problem appears for simple graphics like this: Plot[{ x^2, x^5}, {x, 0, 3}, AxesLabel -> {Style["B", FontSize -> 25], Style["A", Italic, FontSize -> 25]}, TicksStyle -> Directive[Black, 20], PlotStyle -> {{Black, Thickness[0.002]}, {Black, Thickness[0.005]}}] $\endgroup$
    – nail
    Commented May 19, 2013 at 18:46
  • $\begingroup$ I tried it on a Linux server with version 8 and could not reproduce the problem. The output of Export["p.pdf",%] looks identical to that in the notebook. I don't have version 9 on Linux, so I can't check any further, unfortunately. $\endgroup$
    – Jens
    Commented May 19, 2013 at 20:08
  • 1
    $\begingroup$ On Linux v9, Export["p.pdf",%] works for the simple $x^2$ and $x^5$ graphic. Left-clicking the graphic, then right-clicking Save Graphic As... also works. Clicking the cell bracket of the graphic, then clicking File > Save Selection As fails, producing a blank white *.pdf file. $\endgroup$ Commented May 19, 2013 at 22:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.