9
$\begingroup$

Bug introduced in 12.3 or earlier and persists through V13.0.1


I'm using Mathematica 12.3.1 on Windows. Most or not all pages do not show the Underscore character with Patterns. Is this only on my laptop?

e.g. Documentation ref/DirectedEdge

enter image description here

or ref/Cases

enter image description here

When I copy and paste in another Notebook I see the Underscores. @Michael-Mccain and @ Rob-F commented that Magnification plays a role here and it does indeed. I'll report it to Wolfram Support The Underscore is only invisible in Documentation notebooks with Magnification at 100%. Above or below 100% magnification show the underscore.

UPDATE: With magnitude at 100% and resizing the window up to left until the cell contents needs to be repositioned (e.g. the text is to long for the window to fit anymore and then the frontend shows the text on multiple lines)

so here it's not there:

enter image description here

but here it is (at 100%)

enter image description here

$\endgroup$
7
  • 3
    $\begingroup$ Just curious… does changing the magnification make them appear? $\endgroup$
    – B flat
    Aug 10, 2021 at 2:32
  • $\begingroup$ I cannot reproduce this at the three mags I tried (75%/100%125%). I'm running MMA 12.3.1 on Win 10 Home with a 4k display. $\endgroup$
    – david
    Aug 10, 2021 at 18:43
  • 2
    $\begingroup$ I can reproduce it on windows 10 professional with 12.3.1. The strange thing is that, if you copy the command from the help page and paste it into an open notebook, then the underscore now shows up OK. $\endgroup$
    – Nasser
    Aug 10, 2021 at 19:43
  • $\begingroup$ @david interesting. I don't have a 4k monitor. $\endgroup$
    – Lou
    Aug 11, 2021 at 6:05
  • $\begingroup$ @david it also seems that the window size is affecting it. When resize my window and keep the magnification on 100% at a certain size the underscore shows up again $\endgroup$
    – Lou
    Aug 11, 2021 at 7:34

1 Answer 1

10
$\begingroup$

I would have added this as a comment, but as I have insufficient reputation I'll leave this as an answer...

I believe this is a bug, and have reported it to Wolfram Research. It also existed in 12.3.0, but was not present in 12.2.

In my case underscores are visible at higher and lower magnification levels, just not at 100%. They sometimes become visible after changing the cell type, but I can't remember the steps to reproduce this.

Please report this to Wolfram Research, I was under the impression that mine was the first and perhaps only report.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.