I have been using Mathematica 12 on Ubuntu 20.04 for a while now, and everything has been fine.

However, now when I try and open it, it freezes on 'Initializing kernels'. I have also tried running 'mathematica' and 'math' and 'WolframKernel' from the terminal, but they all just freeze. Does anyone have any suggestions?

Edit: I have tried installing the most recent version, but I have the same issue, except it gets to 'Initializing internal preferences', and then my laptop starts whirring lots, and eventually freezes.

  • 1
    $\begingroup$ I am unsure of what is causing your kernal to hang on initialization, I did submit a bug report for this. Did you update to 12.3? $\endgroup$ Aug 4, 2021 at 19:52
  • $\begingroup$ @Shelton_swelton Yes, I've updated to 12.3, but it changed from hanging on 'Initialising kernels' to hanging on 'Initializing internal preferences'. I also made a mistake in my initial post - I'm running Ubuntu 20.04, not 21.04. $\endgroup$
    – user112495
    Aug 4, 2021 at 19:55
  • 1
    $\begingroup$ Thank you for the clarification! hopefully if its a bug, it can be fixed quickly $\endgroup$ Aug 4, 2021 at 19:58
  • 2
    $\begingroup$ Well I'll pass this on, I'll let you know with updates. $\endgroup$ Aug 5, 2021 at 18:40
  • 1
    $\begingroup$ Hello! I have been following the ticket and developers are still working on it. It's fairly tricky and some above my head! Rest assured its not forgotten about. $\endgroup$ Aug 25, 2021 at 18:52

1 Answer 1


Wolfram technical support have managed to resolve the issue for me. I'd recently installed Citrix, and said 'yes' to installing app protection when installing it. Uninstalling Citrix and reinstalling it without app protection resolved the issue.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.