0
$\begingroup$

I am using MMA 12.3.1 on Ubuntu 18.04, and my license support parallelization. The default kernel is Local and I create another one named newKernel. when I launch MMA and choose Local to perform some calculation with parallelization it is working fine. Now if I open new notebook and choose newKernal to do different calculation that also includes parallelization I get this error.

"Unable to communicate with closed link \
LinkObject[\!\(\"/usr/local/Wolfram/Mathematica/12.3/Executables/\
wolfram -noinit -subkernel -pacletreadonly -wstp\"\),125,4]" 

Note that If I restart MMA and run the first code with newKernal it is working fine, but when I run the second code on Local I get the same error.

I tried to uninstall MMA and reinstall again and restart my computer but could not get rid of this. any help please?

For a minimal example one can use any simple code with ParallelSum

$\endgroup$
5
  • $\begingroup$ Did you try the standard way like ParallelDo, ParalleTry etc without manual kernel creation? $\endgroup$
    – Rom38
    Aug 4 at 11:02
  • $\begingroup$ How would that help? and I need tow kernels to do different calculations separately $\endgroup$ Aug 5 at 7:40
  • $\begingroup$ If separately, then try LaunchKernels[] and ParallelEvaluate[cmd, kernID]. It allows autoconfiguration of sub-kernels. $\endgroup$
    – Rom38
    Aug 5 at 8:20
  • $\begingroup$ the problem is that when I LaunchKernels[] in the second notebook it gives the same error mentioned in the question $\endgroup$ Aug 5 at 11:04
  • $\begingroup$ Forget about manually created kernel. Launch the default Local as master, then launch the needed amount of sub-kernels by LaunchKernels and use the ParallelEvaluate[command, {kernIDs}] in different notebooks just changing the kernID. They will work fully separately if you set the DistributedContexts->None. $\endgroup$
    – Rom38
    Aug 6 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.