4
$\begingroup$

On my Windows systems, the autocomplete popup takes extremely long to appear (1-2 secs). This makes typing in Mathematica very uncomfortable for me, as the interface effectively freezes for these 1-2 secs until the popup has appeared.

I experienced this behavior even in totally empty notebooks, on two different laptops (Surface Book 2, Dell XPS), both of which have high-end specs (Win 10, i7 CPU, >= 16 GB RAM, high-DPI display, all drivers up-to-date). However, the problem occurred only in Mathematica version 12.2 and later. It is also rather erratic: when typing a command the second time, the popup usually appears quickly. However, if I move the cursor a bit around in the notebook and then typing the same command again, the popup is again slow. It is almost like Mathematica sometimes rebuilds an internal cache when the popup is triggered. However, that shouldn't take so long for an empty notebook on an i7 CPU.

Some people suggested to delete the contents in $UserBaseDirectory, which, however, didn't help in my case. The problem, in fact, appears also after a fresh install of Mathematica. I know that the popup can be disabled -- but this isn't a solution for me, since I find this feature very useful.

$\endgroup$

2 Answers 2

4
$\begingroup$

In case anyone is still interested, I had the same problem in version 12.3, and solved it by going to Preferences/Advanced/Open option inspector/Editing options/Private editing options/CodeAssistOptions, and leaving AutoPopupEnable as True, but putting the following to False: SCUPopupEnable AutoConvertEnable FloatingElementEnable AttachedBrowserEnable CodeFoldingEnable StringCompleteEnable FileCompleteEnable NetworkFileCompleteEnable

$\endgroup$
1
  • $\begingroup$ After I follow this, it seems like there's a speedup, but I also cannot use "Tab" to accept the suggestion. Why is this happening? I went through the description of the options and I can't figure out which one affects this functionality. $\endgroup$
    – amzon-ex
    Commented Aug 25, 2022 at 5:26
1
$\begingroup$

In v14, autocomplete can be accelerated with a trade-off. Disable "Use fuzzy matching for autocompletions", under "Input Assistance Settings", in section "Interface" of "User | Preferences".

This sacrifices camel-case completion. Unfortunate, but a price I'm willing to pay to eliminate typing latency, which is unacceptable.

Apparently, the fuzzy logic lacks verve.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.