1
$\begingroup$

Let us dsolve that Cauchy problem with 12.3 on Windows 10 Pro:

ClearAll[w, z]; sol = DSolve[{w'[z] == -1/2 - Sqrt[1/4 - 3*w[z]], w[1] == -1}, w[z], z]

{{w[z] -> 1/12 (-2 ProductLog[-((1 - Sqrt[13]) E^(2 + Sqrt[13] - 3 z))] - ProductLog[-((1 - Sqrt[13]) E^(2 + Sqrt[13] - 3 z))]^2)}, {w[ z] -> 1/12 (-2 ProductLog[(-1 + Sqrt[13]) E^( 2 + Sqrt[13] - 3 z)] - ProductLog[(-1 + Sqrt[13]) E^(2 + Sqrt[13] - 3 z)]^2)}}

and a warning "Solve::ifun: Inverse functions are being used by Solve, so some solutions may not be found; use Reduce for complete solution information". Both results are not correct as

Plot[w[z] /. sol[[1]], {z, 1, 2}]
Plot[w[z] /. sol[[2]], {z, 1, 2}]

enter image description here

show: w'[-1]==-1/2-Sqrt[13/4], making use of {w'[z] == -1/2 - Sqrt[1/4 - 3*w[z]], w[1] == -1}, is negative, whereas we see a positive slope at x==1 in the plots. What is the reason of that incorrect result and how to fix it?

$\endgroup$
5
  • $\begingroup$ I have got the result w'[-1] -> -1 - 1/2 ProductLog[(-1 + Sqrt[13]) E^(5 + Sqrt[13])]. Nevertheless, from the first glance, it is not clear what reason brought you to the conclusion that the result w'[-1]==-1/2-Sqrt[13/4] is wrong? Explain please. $\endgroup$ Jun 15, 2021 at 8:17
  • $\begingroup$ @AlexeiBoulbitch: 1. Which version of Mathemaica do you use? 2. The results of DSolve[{w'[z] == -1/2 - Sqrt[1/4 - 3*w[z]], w[1] == -1}, w[z], z] are wrong since their plots have a positive slop at x==1. $\endgroup$
    – user64494
    Jun 15, 2021 at 10:07
  • $\begingroup$ @AlexeiBoulbitch: : I make use of {w'[z] == -1/2 - Sqrt[1/4 - 3*w[z]], w[1] == -1} to obtain w'[-1]==-1/2-Sqrt[13/4]. $\endgroup$
    – user64494
    Jun 15, 2021 at 10:19
  • $\begingroup$ This question is the top of the iceberg. It originates from DSolve[w'[z]^2+w'[z]+3*w[z]==0,w,z] $\endgroup$
    – user64494
    Jun 15, 2021 at 12:39
  • $\begingroup$ Certainly a bug that should be reported to Wolfram, Inc. $\endgroup$
    – bbgodfrey
    Jun 15, 2021 at 17:40

1 Answer 1

1
$\begingroup$

Too long for a comment--not an answer.

Note that clearing w, doesn't clear w'[z].

DSolve does appear to be giving an invalid solution here. Perhaps, it is picking an incorrect branch.

sol = DSolve[{w'[z] == -1/2 - Sqrt[1/4 - 3*w[z]], w[1] == -1}, w[z], 
  z] 

Gives identical solutions: -(1/12) ProductLog[(-1 + Sqrt[13]) E^(2 + Sqrt[13] -3 z)] (2 + ProductLog[(-1 + Sqrt[13]) E^(2 + Sqrt[13] - 3 z)]

solutions = Simplify[w[z] /. sol]

Check ODE

Simplify[D[solutions[[1]], z] - (-1/2 - Sqrt[1/4 - 3*solutions[[1]]]),
  Assumptions -> z \[Element] Reals] (*not zero*)

I think this qualifies as a bug and should be reported.

$\endgroup$
1
  • 1
    $\begingroup$ CraigCarter (@ does not work.) :Thank you. You could split it in two comments. $\endgroup$
    – user64494
    Jun 15, 2021 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.