10
$\begingroup$

After starting Mathematica 12.3, the default window size is like this, it's too small for me, I don’t want to manually drag the window every time. I have tried this,

SetOptions[$FrontEnd, WindowSize -> {800, 800}]

and change "Options Inspector", these are no longer valid, only SetOptions[InputNotebook[], WindowSize -> {800,800}] works, I added it to "init.m", but each time is delayed to take effect, I don't like this solution. I hope there is a simple way to return to the previous behavior.

enter image description here enter image description here

$\endgroup$
1

1 Answer 1

0
$\begingroup$

I found a solution for this, but only works on latest macOS Ventura.

Open the stage manager: enter image description here

Change the setting to this: enter image description here

then reopen Mathematica ,the default notebook should centered

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.