5
$\begingroup$

Bug fixed by 13.1

I am trying to run the following code, taken from https://reference.wolfram.com/language/ref/ContourPlot3D.html:

ContourPlot3D[
 x^4 + y^4 + z^4 - (x^2 + y^2 + z^2)^2 + 3 (x^2 + y^2 + z^2) == 
  3, {x, -2, 2}, {y, -2, 2}, {z, -2, 2}, Mesh -> None, 
 ContourStyle -> 
  Directive[Orange, Opacity[0.8], Specularity[White, 30]]]

The output is a pink box, see here:

pink box error

Why is that and is there a workaround to achieve the intended output that can be seen on the website linked above? I don't have this problem on my Windows machine, only when using my MacBook with M1 chip.

$\endgroup$
8
  • 2
    $\begingroup$ The code works fine here (Mathematica 12.2, Mac OS 11.2.3) so maybe it is a M1 problem? $\endgroup$
    – bill s
    Commented May 9, 2021 at 15:31
  • $\begingroup$ Hm. Probably a bug in Mathematica. After all the M1 ships a new type of graphics chip. And I don't thinkt that Mathematica is already optimized for it. You should tell Wolfram Technical Support about this. In the meantime, you might try to switch software rendering (which is slower!). Go to the menu "Mathematica"->"Preferences..."->"Advanced"->"OpenOptionInspector"->"Graphics Options"->"RenderingOptions" and play with the options there. I'd suggest to set "PreferredGPU" to "Software", to close Mathematica, restart, and see if it got better. $\endgroup$ Commented May 9, 2021 at 15:38
  • $\begingroup$ Also works with v12.2.0 for Mac OS X x86 (64-bit) (December 12, 2020) running on macOS v11.3.1 $\endgroup$
    – Bob Hanlon
    Commented May 9, 2021 at 15:52
  • 8
    $\begingroup$ This is known and IIRC you can set 3DRenderingEngine -> OpenGL globally in the Options Inspector to workaround the issue. $\endgroup$
    – ihojnicki
    Commented May 9, 2021 at 17:38
  • 3
    $\begingroup$ @ihojnicki Thanks, that worked. If you post it as an answer I will accept it. $\endgroup$
    – user505117
    Commented May 10, 2021 at 21:31

1 Answer 1

4
$\begingroup$

Posting the comment from @ihojnicki as an answer:

This is known and IIRC you can set 3DRenderingEngine -> OpenGL globally in the Options Inspector to workaround the issue.

$\endgroup$
1
  • $\begingroup$ This worked for me. Thanks a lot! $\endgroup$ Commented Dec 1, 2022 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.