4
$\begingroup$

In the past I had the same problem but there was an easy solution. Just turn off at the Evaluation -> Debugger in the main menu. But this time it is completely ignored. First of all I do not know why it came on in the first place but I tried flipping it off. When that didn't work I flipped it back on then off and that didn't work either. Not sure what to do next.

I also need to add that I had 4 tagged cells and just now noticed that my tags disappeared too. No other information was lost.

Edit: based on link in comment by Julian Moore it appears that this may be a bug in the Debugger. Unless someone informs of an alternate fix I intend to report this to Wolfram as a possible bug. I'll wait one week from today (5/5/21) or if or when Stack Exchange closes this question. Whichever comes first.

$\endgroup$
9
  • 3
    $\begingroup$ Have a look here: mathematica.stackexchange.com/questions/56152/… and the links within it; I'm not hopeful though; I have had this issue and never satisfactorily resolved it. $\endgroup$ – Julian Moore May 5 at 12:37
  • 2
    $\begingroup$ It's a bug. The only way to remove the debugger windows once they get into that state is to quit the kernel. $\endgroup$ – ihojnicki May 5 at 20:26
  • 1
    $\begingroup$ You should report this anyways to wolfram tech support. Why would you wait? $\endgroup$ – CA Trevillian May 30 at 15:51
  • 2
    $\begingroup$ @JulesManson, you could report the reappearing debugger window problem if you want... but it has already been fixed and should be in 12.3.1. $\endgroup$ – ihojnicki May 30 at 18:33
  • 2
    $\begingroup$ No worries. It will not be the first time a bug is reported after it has been fixed. $\endgroup$ – ihojnicki May 30 at 19:33
0
$\begingroup$

This May Work

I found a relatively easy solution that worked for me. Changing the Stylesheet removed the Debugger toolbar. But first please make certain that the Debugger is not checked on in Evaluation menu.

The next two points are not tested but it appears that the bug may somehow be linked to stylesheets. If the former did not work for you I ask that you try the following in the order given. Please don't forget to report back your findings in the comments.

  1. Do Format -> Edit Stylesheet to determine if Debugger is turned on there. If it is on uncheck it. Now close the stylesheet. I speculate that this may work.

  2. If point 1 does not apply or did not work please reopen the current stylesheet and do a simple edit (one that is easily undone) then close it. If it's an edit you don't need reopen the stylesheet once again to delete or change the edit.

  3. Please report back your findings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.