2
$\begingroup$

I'm trying to make a legend to a ListPlot. There is the problem, several letters are displayed in itallic and some in the plain slant. How can I fix this?enter image description here

$\endgroup$
4
  • $\begingroup$ try wrapping your legend labels with Style[#, SingleLetterItalics -> False]&? $\endgroup$
    – kglr
    Mar 28 '21 at 10:06
  • $\begingroup$ woeks! Thanks! But it does not work on the legend as whole, I've wrapped each of legend's elements. Maybe there is a way to act on the legend as a whole? $\endgroup$
    – Ivan
    Mar 28 '21 at 11:56
  • $\begingroup$ Welcome to Mathematica.SE! I suggest the following: 1) As you receive help, try to give it too, by answering questions in your area of expertise. 2) Take the tour! 3) When you see good questions and answers, vote them up by clicking the gray triangles, because the credibility of the system is based on the reputation gained by users sharing their knowledge. Also, please remember to accept the answer, if any, that solves your problem, by clicking the checkmark sign! $\endgroup$
    – Michael E2
    Mar 28 '21 at 16:02
  • 3
    $\begingroup$ People here generally like users to post code as Mathematica code instead of just images or TeX, so they can copy-paste it. It makes it convenient for them and more likely you will get someone to help you. You may find the meta Q&A, How to copy code from Mathematica so it looks good on this site, helpful $\endgroup$
    – Michael E2
    Mar 28 '21 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.