0
$\begingroup$

Bit of a bizarre problem I'm having (well, more a question than a problem). I am trying to solve an integral, which I queried using the online wolfram alpha website. The input and output are interpreted correctly and I get what I want.

https://www.wolframalpha.com/input/?i=Integrate%5B%28b+%2B+%28h+t%29%2FT%29Exp%5B+-2Piif*t%5D%2C+%7Bt%2C+-W%2C+-W+-+T%7D%5D enter image description here

Now I want to do the exact same thing by calling wolfram alpha in mathematica (using ==). However, when I type == and then use the same copyable plaintext offered by the url above, all of a sudden I get the error that Wolfram|Alpha doesn't know how to interpret my input, and the input interpretation is just 'f' (screenshot attached) enter image description here

Why does it work without issue on the wolfram alpha web-page but not when I try to use wolfram alpha through mathematica? Thanks

$\endgroup$
3
  • 2
    $\begingroup$ MMA version 12.1. Just tried and can not reproduce the error. Instead I get the input back with an "+" at the right upper edge, where I can choose the format of the output. $\endgroup$ – Daniel Huber Mar 26 at 18:00
  • $\begingroup$ In version 12 on m1 ARM, the code doesn't give any errors, assumes that i is complex...then fails to load the the result....however when clicking the given link, it forwards to wolfram alpha in the browser, which then loads correctly...so in v12 there is a similar issue. $\endgroup$ – morbo Mar 27 at 18:05
  • $\begingroup$ Just tried this on Mathematica 12 instead of Mathematica 10, I just get the input back again but it does not load the actual answer. $\endgroup$ – hex93 Mar 30 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.