1
$\begingroup$

Just a quick question, I need to draw some phase plots via Mathematica and saw the application equation trekker. This seemed helpful and legit from a Mathematica website however when I tried to apply it, it doesn't give any plots what so ever.

The code that I run is displayed under here. It opens the display form but there are no plots can't edit anything

I am using Mathematica 12.1.1 and Windows 10

<< EquationTrekker`

%This runs fine%

EquationTrekker[y''[x] + 2*y[x] == 0, y, {x, 0, Pi}]

Errors given:

PropertyValue::pvobj: canvas is not an object with properties. PropertyValue::pvobj: trekPane is not an object with properties. PropertyValue::poi: -- Message text not found -- (PropertyValue[{canvas,canvasPane,All},Name->trekPane]) (1) PropertyValue::poi: -- Message text not found -- (PropertyValue[{trekPane,trekController,All},Name->trekController]) (1)

If somebody could enlighten me with some help that would be great!

$\endgroup$
1
  • 4
    $\begingroup$ This is a very old, unmaintained package that I expect might be removed from Mathematica in the future (many other old standard packages have already been removed). I would not spend too much time on trying to get it working in recent Mathematica versions. $\endgroup$ – Szabolcs Feb 15 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.