I have Mathematica setup normally and connections work. However, when I want to use it to connect through my SSH tunnel program (Tunnelier), it throws the error

PacletSiteUpdate::err: An error occurred attempting to update paclet information from site http://pacletserver.wolfram.com. Server returned nothing (no headers, no data)

meanwhile I get the following error message in Tunnelier:

(unrecognized proxy protocol) connection from failed: Unsupported client protocol; the client may be expecting a regular HTTP proxy

I have left the HTTP, HTTPS and FTP proxy fields blank, and only filled in the SOCKS IP ( and the port (9494). Firefox and IE can successfully connect via the same SSH tunnel. I have also tried it with a similarly working Putty tunnel, with it throwing the exact same error, just with no output from the Putty client.

  • $\begingroup$ Did you try this troubleshooting page? What did you see? Specifically: "If the Test Network Connectivity button (described in "Test Internet Connectivity") fails after a minutes-long delay, an incorrect SOCKS proxy configuration is likely to be the problem. Mathematica does not require a SOCKS proxy, but will attempt to use one if the SOCKS proxy information is available." $\endgroup$ Apr 25, 2013 at 12:37
  • $\begingroup$ What does $InternetProxyRules say? $\endgroup$ Apr 25, 2013 at 12:38
  • $\begingroup$ With "...and connections work" you mean the connections work for Mathematica or in general, but not for Mathematica? $\endgroup$ Apr 25, 2013 at 14:00
  • $\begingroup$ I mean that connections work for Mathematica when not using a proxy. $\endgroup$
    – March Ho
    Apr 26, 2013 at 15:03
  • 1
    $\begingroup$ I tried to set up a SSH port forwarding system with Tunnelier that I just downloaded. It took me some time to get FireFox and IE running, but they work now. Mathematica doesn't. Tunnelier gives me the same error message: "(unrecognized proxy protocol) connection from failed: Unsupported client protocol; the client may be expecting a regular HTTP proxy." $\endgroup$ Apr 27, 2013 at 0:08

1 Answer 1


As I wrote in my earlier comment, I got the same error messages in the two-PC client/server Tunnelier system I set up specifically for this question. Apparently Mathematica's handling of proxies is not really up to the task, as I have had many problems with them before (in particular proxies in an NTLM environment).

I did have some success by adding the proxy Privoxy between Mathematica and Tunnelier. I configured Privoxy to connect to Tunnelier as parent and let it forward connections by setting the "SOCKS/HTTP proxy forwarding" option to enabled. With Mathematica configured to use Privoxy as proxy (not with SOCKS but using HTTP) the connection test in Mathematica's network preferences panel works, as do many of the cumputable data functions (FinancialData, CityData,WeatherData to name a few). However others, like ParticleData, systematically fail.

Privoxy has many parameters to tune (connection keep-alive, time-outs etc.) and there may be a solution to find there for those functions that currently do not work.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.