3
$\begingroup$

I want to have a plot with polar axes, but the axes numbers get alway lost or I can't see them in their full size. The problem is particularly bad at the left and right edges. Also, it seems that the PlotRange option doesn't work. Maybe someone has an idea how I can solve the problem. I would be very happy about help.

ListPolarPlot[list, 
  PolarPolarAxes -> Automatic, PolarGridLines -> Automatic, 
  PolarTicks -> {"Degrees", All}, PlotStyle -> Blue, PlotRange -> All]

enter image description here

$\endgroup$
3
  • $\begingroup$ Please edit your question, and add the code from the image and other code needed to reproduce the plot. Posting the code makes it easier for us to try it by copying and pasting it rather than typing it from scratch. $\endgroup$
    – creidhne
    Jan 10 '21 at 16:38
  • $\begingroup$ Try the ImagePadding -> All option which might help. $\endgroup$
    – creidhne
    Jan 10 '21 at 16:50
  • $\begingroup$ @creidhne ImagePadding -> All does not work. :( $\endgroup$
    – Nick
    Jan 10 '21 at 16:55
2
$\begingroup$

The ImagePadding option will fix this problem. Its value depends on the plot and labels you use. In this case, ImagePadding -> Scaled[.05] displays the numbers.

list = Table[{r,Cos[2r]},{r,0,2\[Pi],\[Pi]/24}];
ListPolarPlot[list, PolarAxes -> Automatic, PolarGridLines -> Automatic,
  PolarTicks -> {"Degrees", All}, PlotStyle -> Blue, PlotRange -> All,
  ImagePadding -> Scaled[.05]]
$\endgroup$
1
  • $\begingroup$ PlotRangePadding is a better solution. See m_goldberg's answer. $\endgroup$
    – creidhne
    Jan 10 '21 at 17:43
1
$\begingroup$

Plot range padding also works. Like so:

ListPolarPlot[Table[Sin[2 i], {i, 0, 2 Pi, 2 Pi/100}],
  PolarAxes -> True,
  PolarGridLines -> Automatic,
  PolarTicks -> {"Degrees", Automatic},
  PlotStyle -> Blue,
  PlotRange -> All,
  PlotRangePadding -> Scaled[.12]]

plot

$\endgroup$
3
  • $\begingroup$ But the numbers are also cut off in this picture. At least in the range 105 to 210. Dont you see it? :( $\endgroup$
    – Nick
    Jan 10 '21 at 17:33
  • $\begingroup$ @Nick Yes, I made mistake. I have revised my answer. $\endgroup$
    – m_goldberg
    Jan 10 '21 at 17:36
  • $\begingroup$ Thank you! It works! $\endgroup$
    – Nick
    Jan 10 '21 at 17:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.