Recently (I only noticed in V12.2), website URLs, such as https://www.wolfram.com, became active in text cells in notebooks. The "hot" nature makes the links hard to edit, since any click on them calls up a browser. Is there a way to turn it off and back on?


1 Answer 1


The functionality is controlled by setting the cell option on the desired cell(s):

CodeAssistOptions -> {"AutoDetectHyperlinks" -> False}  (* Off *)
CodeAssistOptions -> {"AutoDetectHyperlinks" -> True}   (* On  *)

The option can also be applied globally by setting it for the Front End:

 CodeAssistOptions -> {"AutoDetectHyperlinks" -> False}]

The option can be applied to a single notebook, which (as usual) will override the Front End setting:

 CodeAssistOptions -> {"AutoDetectHyperlinks" -> True}]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.