5
$\begingroup$

The code

g = Graphics[{AbsoluteThickness[20], Arrowheads[0.5], Arrow[{{0, 0}, {1, 1}}]}, PlotRange -> {{0, 1.1}, {0, 1.1}}]
Export["Arrow.eps", g];

produces an image with a corrupted arrow tip. I'm using version 12.1 on MacOS 11.1.

Here's the result I get enter image description here

How can I work around this problem?

Edit: Tried in Windows 10: Same problem.

$\endgroup$
6
  • 1
    $\begingroup$ I have reported a very similar bug before. Please do report it to Wolfram. If you open it with an editor like Illustrator, you will see that the arrowhead has an outline (stroke) of non-zero width which is responsible for this problem. It should not. $\endgroup$ – Szabolcs Dec 20 '20 at 9:15
  • $\begingroup$ You can export a rasterized version. Or you can open the output in a graphics editor and remove the strong from the arrowheads. These are of course not ideal. I would try creating my own custom arrowhead so I can control the stroke. Let us know if that approach worked. $\endgroup$ – Szabolcs Dec 20 '20 at 11:34
  • 5
    $\begingroup$ Does this answer your question? How to stop Mathematica 12.1 from chopping off the axes arrows? $\endgroup$ – CA Trevillian Dec 20 '20 at 14:17
  • 1
    $\begingroup$ It would be nice to see this problem solved without so many workarounds, though. I think the answer there from HD might work for you? $\endgroup$ – CA Trevillian Dec 20 '20 at 14:19
  • $\begingroup$ Who/What is HD? $\endgroup$ – Wynne Dec 20 '20 at 21:20