Mathematica loves telling the user that it is "Formatting Notebook Contents" during DataModeler model searches. The problem is that, even though Mathematica is in the background, that panel pops up front & center and steals focus from the application actually being worked upon.

Needless to say, my users get ticked off at this intrusive behavior on the part of the front end.

In my opinion, there is a design flaw in the sense that WRI should not steal focus if it is a background app.

That said, is there a way to either suppress the message entirely or to not steal focus from the foreground app? Alternately, is there a way to detect that Mathematica is in the background to intelligently suppress front end graphics?


  • $\begingroup$ how are you starting mathematica? clicking on a *.nb? downloading a *.nb clicking open? launching from the start menu or desktop shortcut? windows startup folder? are you starting mathematica from a shell script or some kind of automation or toolchain? if you are launching mathematica from the command line via shell script, what arguments are you passing in? the shortest answer I can give you is that if you are developing a .net application on windows, this would be an easy thing to fix. or you can wait for WRI to fix it. decide if you are more concerned with "always on top" or the focus. $\endgroup$
    – acacia
    Oct 24, 2020 at 17:32
  • 1
    $\begingroup$ DataModelerGUI[ ] (100% Mma) is normally launched via a palette click with Mathematica running. The user beating me about this is running MacOS on an 18-core iMac Pro with 16 sub-kernels crunching their model searches independently. While the model search is going, she is trying to work with other applications (Mail, Keynote, Pages, Tableau, etc.). The goal is any solution which doesn't impede productive work on the part of the user — killing the panel, having it have lower priority than the front app or simply an ability for Mathematica to recognize it is not front are all equally good. $\endgroup$ Oct 24, 2020 at 22:56
  • 1
    $\begingroup$ @MarkKotanchek Yes, I got annoyed by these useless popups, too. Try something like FrontEndExecute @ FrontEnd`NotebookSuspendScreenUpdates[nb] . No guarantee, though. I also optimized programmatic notebook generation. Feel free to contact me if needed. $\endgroup$ Oct 27, 2020 at 17:47
  • $\begingroup$ Is there a good simple representative example that shows the problem? Ideally an example that works on a stock unmodified Mathematica installation? I don't fully understand the problem from the description, but I am wondering if scheduled tasks can at least avoid these problems. $\endgroup$ Oct 29, 2020 at 17:12
  • $\begingroup$ @RolfMertig Thanks Rolf. I sent you an email but it might have gone to junk mail. $\endgroup$ Nov 2, 2020 at 21:10

1 Answer 1


Looks like this is a setting you can turn off. There is a similar post here that will probably work for you. I do not have an OSX machine to test this myself.

Mathematica steals focus after finishing computation

  • $\begingroup$ It doesn't appear that MacOS has such a feature — although, it may be buried in their system preferences. You did inspire me to tell the user to hide Mathematica to see if that helped and it appears all of the subkernels keep crunching without the formatting panel popping up. There is still a flickering that happens so that doesn't appear to be a complete solution. Of course, I'd prefer a solution that doesn't require user intervention so I don't think we are there yet for addressing the issue. $\endgroup$ Oct 25, 2020 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.