0
$\begingroup$

I'm trying to a solve of system of partial differential equation, but Mathematica is giving some error. Can anyone help me please to find out the error.

EQ1 = (1/P*r)*D[T[y, τ], {y, 2}] + 
   u[y, τ]*D[T[y, τ], {y, 1}] + -2*T[y, τ]*
    D[u[y, τ], {y, 1}] - S*D[T[y, τ], {τ, 1}] + 
   EE*c*(D[u[y, τ], {y, 2}])^2;
EQ2 = D[u[y, τ], {y, 3}] + u[y, τ]*D[u[y, τ], {y, 2}] -
    S*D[u[y, τ], {y, 1}, {τ, 1}] - (D[
     u[y, τ], {y, 1}])^2;
INC1 = Derivative[1, 0][u][0, τ] - Sin[τ];
INC2 = T[0, τ] - 1;
INC3 = u[0, τ];
EE = 1; c = 1; P = 1; r = 1; S = 1; NDSolve[{EQ1 == 0, EQ2 == 0, 
  INC1 == 0, INC2 == 0, INC3 == 0}, {u, T}, {τ, 0, 10}, {y, -10, 
  10}]
$\endgroup$
1
$\begingroup$

I'm not sure what you are trying to model here, but there's not enough initial and boundary conditions for the system to be solved. I tried to just add a few, this works but I'm not sure exactly which initial and boundary conditions you need for your problem

(*your eqs and conditions*)
INC4 = Derivative[1, 0][T][0, τ];
INC5 = Derivative[2, 0][u][0, τ];
INC6 = u[y, 0] + T[y, 0];

NDSolve[{EQ1 == 0, EQ2 == 0, INC1 == 0, INC2 == 0, INC3 == 0, 
  INC4 == 0, INC5 == 0, INC6 == 0}, {u, T}, {τ, 0, 10}, {y, -10, 
  10}]
$\endgroup$
2
  • $\begingroup$ thanks @luigi for your effort, but code is not working again if I add the initial conditions you have mentioned. $\endgroup$ – MMS Oct 7 '20 at 18:39
  • $\begingroup$ Initial conditions and boundary conditions need to be consistent. $\endgroup$ – anderstood Oct 8 '20 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.