2
$\begingroup$
x = 0; Dynamic[{x, Button["+1", Pause[6]; x++]}, SynchronousUpdating -> False]

The documentation states that Dynamic and Manipulate will abort synchronous computations that take longer than 5 seconds. The stated solution to this is to set SynchronousUpdating to False. That does not seem to work here. If I pause for 5 or fewer seconds it always works, but if I pause for 6 or more seconds, x always stays at 0 no matter the setting for SynchronousUpdating.

$\endgroup$
3
$\begingroup$

Eh, the answer lay a click deeper in the documentation. You need to set Method->"Queued" on Button, then you don't even need to disable SynchronousUpdating. This now works as expected.

x = 0; Dynamic[Button[x, Pause[6]; x++, Method -> "Queued"]]
$\endgroup$
  • $\begingroup$ +1 for self-answering and sharing the solution. $\endgroup$ – Mr.Wizard Apr 11 '13 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.