1
$\begingroup$

I'm starting to learn Mathematica, and in the book that I'm reading the author presented the commands Simplify and Expand. Now, the example in the book was the following:

Simplify[(x^3 - y^3)/(x - y)]

In the above form , evaluation works and outputs

x^2 + x y + y^2

The problem is, when I use the typesetting notation, the function doesn't work:

Simplify[$\frac{x^3 - y^3}{x-y}$]

The above command outputs $\frac{x^3 - y^3}{x-y}$, instead of the simplified form. The same happens for the command "Expand".

Is there a way around this? As asked in the comment, here is the output of

Simplify[$\frac{x^3 - y^3}{x-y}$]\FullForm

\!\(
TagBox[
StyleBox[
RowBox[{"Times", "[", 
RowBox[{
RowBox[{"Power", "[", 
RowBox[{
RowBox[{"Plus", "[", 
RowBox[{"x", ",", 
RowBox[{"Times", "[", 
RowBox[{
RowBox[{"-", "1"}], ",", "y"}], "]"}]}], "]"}], ",", 
RowBox[{"-", "1"}]}], "]"}], ",", 
RowBox[{"Plus", "[", 
RowBox[{"x\\.b3", ",", 
RowBox[{"Times", "[", 
RowBox[{
RowBox[{"-", "1"}], ",", "y\\.b3"}], "]"}]}], "]"}]}], "]"}],
ShowSpecialCharacters->False,
ShowStringCharacters->True,
NumberMarks->True],
FullForm]\)
$\endgroup$
5
  • $\begingroup$ Can you add //FullForm (i.e., Simplify[..] //FullForm)? This should make clear what is going wrong. $\endgroup$
    – Carl Woll
    Sep 12 '20 at 22:05
  • $\begingroup$ Will try. Thanks. $\endgroup$ Sep 12 '20 at 22:08
  • $\begingroup$ I updated the question with the output of the FullForm, but I'm new to Mathematica, I have not been able to identify the issue. $\endgroup$ Sep 12 '20 at 22:12
  • 2
    $\begingroup$ How would you enter x^3 using "typesetting notation"? It seems that your x^3 is actually x followed by the unicode character $\unicode{179}$. That is not how you typeset x^3 in Mathematica. Instead use Ctrl-^ to create a superscript. $\endgroup$
    – Carl Woll
    Sep 12 '20 at 22:47
  • $\begingroup$ I think it might be a configuration in my Ubuntu then. You are right, by using crtl-^ it worked. Thanks. $\endgroup$ Sep 12 '20 at 22:50
2
$\begingroup$

I think you must have made a mistake when entering the expression in typeset form. When I pasted the LaTeX form

$\frac{x^3 - y^3}{x-y}$

After entering

Simplify[

and pasting the LaTeX form, I got a dialog pane asking me if wanted the front-end to translate from LaTeX to Mathematica typesetting. I said yes, and then adding the closing bracket and evaluating got the following result

simplify

In box form the Simplify expression looks like this:

boxes

which not at all what you have. I also entered the typeset expression directly into my notebook with the Basic Math Assistant palette and got the same result.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.