3
$\begingroup$

I have tried to install Mathematica 12.1.1 on my Linux system. But the WolframScripts installing asked me that I should install it by root or sudo. I cannot get the root account and I want to install it just for my current user. How can I do that?


I have installed it with rpm2cpio, then I add all the [path]/bin paths to the ~/.bashrc and source it. But there is another question that occurred when I run wolframscript directly:

[quanfeng@XEON ~]$ wolframscript
/home/quanfeng/software/wolfram/bin/WolframKernel: line 15: uname: command not found
Cannot determine operating system.

However, if I run WolframKernel directly, there is no any question:

[quanfeng@XEON bin]$ WolframKernel
Mathematica 12.1.1 Kernel for Linux x86 (64-bit)
Copyright 1988-2020 Wolfram Research, Inc.

In[1]:=
In[1]:= Exit[]

So, what does the message Cannot determine operating system mean and what should I do?


I found that the wolframscript cannot find the system command such as uname correctly, why and how to fix it?

$\endgroup$
  • $\begingroup$ IIRC, just tell the install script to use paths in your local tree, then add whatever path used for the binaries to your path list. $\endgroup$ – ciao Aug 14 at 0:43
  • 1
    $\begingroup$ @ciao , hello. I have renewed my question, and can you help me? $\endgroup$ – Fenyutanchan Wu Aug 14 at 2:24
3
$\begingroup$

I have already solved this problem. The critical point is that the root user has installed the Mathematica 11.2 with its WolframScript and the command rpm2cpio wolframscript.rpm | cpio -ivdm will extract the link file ./usr/bin/wolframscript linking to the file /opt/.../wolframscript which is for Mathematica 11.2. Therefore, I run export PATH=[The path of the binary file named "wolframscript" you have extracted before]:$PATH and WolframScript runs correctly.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.