2
$\begingroup$

I'm using Mathematica 12.0 Student Edition and have python 3.7.6 instilled in anaconda and 3.7.8 installed via Microsoft Store. I have followed the reference instructions here but to no avail. The following is all that is displayed after opening Mathematica and attempting to locate python.

enter image description here

Is there something with $Path that I'm missing?

The documentation seems to suggest that the steps in the link listed above are all I need to follow. I cant find anyone else with this issue so any and all help is greatly appreciated.


I tried the same thing with Julia (1.5.0), follwing the instructions found Here, but I also get this instead:

enter image description here

$\endgroup$
5
$\begingroup$

Maybe you need to register the location of Python manually:

RegisterExternalEvaluator["Python","D:\\Python3\\python.exe"]
$\endgroup$
  • $\begingroup$ Yeah, that did it. Thank you! I tried this earlier and it didn't work so I'm at a loss as for why it suddenly decided to start working now. :/ Also, Julia is only experimentally available in 12.1 not 12.0 $\endgroup$ – Joshua Bocanegra Aug 12 '20 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.