6
$\begingroup$

Consider the following piece of code

Manipulate[
Graphics[
{{Gray, Line@Table[RandomReal[1.5 {-1, 1}, {2, 2}], {10000}]},
Dynamic[Disk[{0.1 a Cos[a], 0.12 Sin[a]}, 0.1]]}, PlotRange -> 1.5,
FrameTicks -> False, Frame -> True], {a, 0, 4 \[Pi]}]

Running the above code I find that the Graphics in newer versions of Mathematica (e.g. version 12.1) are jerky and are rendered considerably slower. I ran the same code in version 9.0 and it runs relatively smoothly.

Does someone know why this is so? and what changed between the older and the newer versions of Mathematica?

$\endgroup$
5
  • $\begingroup$ Did you try this on a fresh Mathematica session (i.e directly after starting Mathematica)? For me, I cannot see any difference between version 7.0 and 12.1, with both feeling relatively responsive (this is on Windows 10) $\endgroup$
    – Lukas Lang
    Commented Jul 31, 2020 at 15:53
  • $\begingroup$ @LukasLang Yes. I tried in a fresh session. The kernel just hangs and I have to force Mathematica shut from taskbar when I drag the slider in Manipulate. I have no idea what is happening. My version is 12.1.1. Let me change it in the question. $\endgroup$
    – Ali Hashmi
    Commented Jul 31, 2020 at 16:06
  • $\begingroup$ It has a slow-ish framerate for me on Windows10 12.1.1 but it's usuable. Maybe this is a problem with your graphics driver or anti-virus software. You should pop open your taskmgr / ActivityMonitor / top depending on which OS you're on and see if any other processes have high cpu/memory usage, and what Mathematica is doing too. $\endgroup$
    – flinty
    Commented Jul 31, 2020 at 16:21
  • $\begingroup$ @flinty I noticed that I don't have this problem with version 12.0. I am using Windows 10 as well. I guess if I am correct WRI made some changes between 12.0 and 12.1 to bring high-resolution graphics to windows. The graphics look more crisp on 12.1 but the kernel crashes after I move the slider, and the slide is extremely sluggish. My windows is zoomed to a 100% and my laptop screen is 4k (not that it would make any difference). $\endgroup$
    – Ali Hashmi
    Commented Jul 31, 2020 at 16:35
  • $\begingroup$ @LukasLang kindly check my answer. any workarounds? $\endgroup$
    – Ali Hashmi
    Commented Jul 31, 2020 at 16:44

1 Answer 1

1
$\begingroup$

This is not an answer but I think I found the culprit that is causing the kernel in 12.1.1 to crash. It is the kernel calling the OpenJDK Platform Binary. The same code (see the question) runs fine in 12.0 perhaps because the kernel calls the Java Platform SE Binary instead.

This is task manager for Mathematica version 12.0

enter image description here

Task manager for Mathematica version 12.1.1

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ I doubt the JVM version has anything to do with it - the Java instance is not used for graphics rendering at all as far as I know. When dragging the slider around in 12.1.1.0 for example, only the CPU usage of the front-end process goes up, the others stay low (this is on a 4K desktop PC with scaling set to 125%). I was also unable to reproduce the kernel crash you are talking about - can you try to reset all Mathematica settings, as explained here, and see what happens? Otherwise I'd suggest you contact Wolfram support, as they can probably help you be $\endgroup$
    – Lukas Lang
    Commented Jul 31, 2020 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.