0
$\begingroup$

I want to plot the following code, in 1D. However, code displayed below is not being plotted; no results or errors are displayed

Plot[((16*10^-12)/(4*π*8.854188*Sqrt[4*π*0.125*10^6*t])*(Sum[Integrate[((\[Minus]1)^m E^(\[Minus](x\[Minus]200m-99.5)^2/4*0.125*10^6*t))/(99.5-x)^2,{x,0,100}],{m,\[Minus]∞,+∞}]+Sum[Integrate[((\[Minus]1)^m E^(\[Minus](x\[Minus]200m+99.5)^2/4*0.125*10^6*t))/(99.5-x)^2,{x,0,100}],{m,\[Minus]∞,+∞}])),{t,0,100},PlotRange->All]

code doesn't run. Could you please help? I tried to use Plot instead of Plot3D as i now used just the range of {t,0,100}

thanks in advance

$\endgroup$
  • 4
    $\begingroup$ Please copy your code into the post - do not post screenshots. $\endgroup$ – flinty Jul 28 at 12:13
  • 3
    $\begingroup$ You are using { } in your formula ... why? These are for lists and related constructs - use () if you mean to delimit your sub-expressions with parentheses. Your error is because you have two ranges {t,0,100} and what looks like {x',0,100}. But Plot only supports one range. Do you want Plot3D instead? $\endgroup$ – flinty Jul 28 at 12:17
  • $\begingroup$ thanks @flinty, i tried to run the below code in screenshot attached in initial post (code too long to add it here as a comment): but i get no result at all $\endgroup$ – Emma Jul 28 at 12:24
  • 1
    $\begingroup$ but x' is not the derivative of x Yes which is why you should not write x' because it turns it into a Derivative[1][x]. $\endgroup$ – flinty Jul 28 at 12:45
  • 1
    $\begingroup$ The infinite sums are very slow and Plot has to run these over a lot of points. Perhaps you can find a way to put your expression in a different form, or pre-calculate the sums / integrals in a closed form that evaluates more efficiently. $\endgroup$ – flinty Jul 28 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.