6
$\begingroup$

Without any obvious reason Mathematica started to emit a beep after each evaluation, even when it is error free. Why is that, and how can I turn it off? I tried restarting Mathematica to no avail, and this post did not help either.

$\endgroup$
6
  • $\begingroup$ Which MMA are you running, and on which operating system? $\endgroup$
    – prog9910
    Jul 21 '20 at 19:33
  • 5
    $\begingroup$ Go to Help -> Why the Beep...? and see what it says. $\endgroup$
    – Szabolcs
    Jul 21 '20 at 19:50
  • 1
    $\begingroup$ try resetting Mathematica as explained here support.wolfram.com/12464?src=mathematica $\endgroup$
    – Nasser
    Jul 21 '20 at 21:26
  • 2
    $\begingroup$ @Szabolcs This did the trick. I have activated automating save after evaluation, but the notebook I am using was still not saved and hence the beep. Thanks a lot, I would have never thought of that. $\endgroup$
    – Pxx
    Jul 22 '20 at 8:30
  • 2
    $\begingroup$ @Jxx It'd be nice if you could post a self-answer where you mention both Help -> Why The Beep and what the problem turned out to be in the end. $\endgroup$
    – Szabolcs
    Jul 22 '20 at 8:38
6
$\begingroup$

You can open Option Inspector and change the prompt of calculation completion to other options.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Unfortunately "beep" was already not active there. But the problem was solved in the comments above. Thanks anyway! $\endgroup$
    – Pxx
    Jul 22 '20 at 8:29
2
$\begingroup$

The problem was that I activated the automatic save after each evaluation, but was working on a notebook that had not been saved yet - hence the beep. As mentioned in the comments, going to Help and clicking on Why the Beep? showed clearly why this was happening:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.