9
$\begingroup$

V 12.1.1, starting a kernel, e.g. by entering wolframscript in the shell, takes an unexpectedly long time (~5 min, the time elapsed between pressing Enter and the showing-up of In[1] := ); but the same operation for V 12.0 takes merely ~3 sec.

I wonder if I am the only one experiencing this.


Update

Also, inspired by @Ordinaryusers68 's answer, I find these two posts:

where, an option -nopaclet is mentioned when starting the kernel.

$\endgroup$
2
  • 2
    $\begingroup$ Thanks so much for bringing this up! I have similar problems since Mma 12.0, but I was to lazy to debug them properly. BTW, in my case this happens even when the system has a proper internet connection. For me PacletManager$AllowInternet = False' works best. I guess I'll put this into my init.m and update the paclets from time to time by hand. $\endgroup$
    – vsht
    Commented Jul 20, 2020 at 18:55
  • $\begingroup$ Hi, @vsht , thx for your information. Actually, I had hesitated for a quite long time before I decided to put this post up. And I am really happy if it can help anyone. :) $\endgroup$ Commented Jul 21, 2020 at 2:01

1 Answer 1

6
$\begingroup$

I don’t know if the problem you encountered is the same as the problem described in this post. If the same, you need to disable automatic updates.

This failure is caused by the paclet update system. Just turn off this automatic update. The easiest way to close the update is to delete the "PacletSiteData_10.pmd2" file.

$\endgroup$
4
  • 1
    $\begingroup$ Thx for the response! $\endgroup$ Commented Jul 18, 2020 at 6:28
  • $\begingroup$ BTW, where is that file located? $\endgroup$ Commented Jul 18, 2020 at 6:58
  • 3
    $\begingroup$ @ΑλέξανδροςΖεγγ By using the Everything tool to search for the PacletSiteData keyword, I found that its location is C:\Users\xxx\AppData\Roaming\Mathematica\Paclets\Configuration\pacletSiteData_12.pmd2. $\endgroup$ Commented Jul 18, 2020 at 7:10
  • 2
    $\begingroup$ @Ordinaryusers68 - +1 on "everything" - seriously useful tool. $\endgroup$
    – ciao
    Commented Jul 18, 2020 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.