I'm at my wit's end. I'm using MMA version (for Mac), and the front end is behaving bizarrely.

  1. When I've chosen Subsection style, there are times when I'm writing that the front end randomly (?) upgrades the style to Section

  2. Typing "=" in the middle of a mathematical expression sometimes (actually often) leads to the whole expression being converted to Text Display with a leading orange box with an equals sign in it

  3. Other similar issues, for example a cell autoformatted to Python input

I've tried turning off things such as "AutoConvertEnable" in the OptionsInspector (is this even the correct option to turn off?), but clicking the box only makes the option bold, and the change doesn't stick. When I use a command such as "SetOptions[$FrontEndSession, "FormatTypeAutoConvert" -> False]", I can literally watch the OptionsInspector change from True to False with the use of the command, but then change right back to True again once I start a new line.

Please help!!

Edit: The version I was running was dated June 9, 2020. But the problems persist in the latest version I downloaded as of this morning, July 15, 2020, whose version is dated June 19, 2020.

When I change versions, I only replace the app in Applications folder. Maybe some files are stored elsewhere that got corrupted? Note that the problem persists even after wiping the /Applications/Mathematica.app/, /Library/Mathematica/, ~/Library/Mathematica/, and ~/Library/Wolfram/ folders (there was no ~/Library/Caches/Wolfram/ folder) and reinstalling.

Edit 2: Thank you very much to the two commenters who noted that starting any cell with "=" changes the cell style. I've been using the cleanly installed newest MMA binary (June 19, 2020) without a hitch. I believe the problem is solved, and so I'll accept the reinstall suggestion as correct. What a massive relief. Thank you all so much!

  • 5
    $\begingroup$ There was a second release of What does $Version return? The date should be 19 June or later. $\endgroup$
    – Edmund
    Commented Jul 14, 2020 at 22:27
  • $\begingroup$ I edited my question to answer you comment. I've now seen the problem in the versions dated June 9 and also June 19, 2020 $\endgroup$ Commented Jul 15, 2020 at 7:29

2 Answers 2


I also ran into similar problems with 12.1.1 for Mac. Check the MD5 checksum of the version you are using. There was an initial version posted when 12.1.1 was first released that contained some front-end bugs. It was rather quietly replaced with a revised version of 12.1.1. The MD5 checksum of the latest version, which seems to work much better, should be: 8f8dadb67974755bc4a5935393581e5d

  • $\begingroup$ I wanted to avoid downloading and reinstalling, but your comment made me bite the bullet. Unfortunately, the problems are still there. (The first thing I did was type an equals sign, and it immediately converted to an orange box with a white equals sign inside.) $\endgroup$ Commented Jul 15, 2020 at 7:23
  • 1
    $\begingroup$ @WAH that sounds like normal functionality, at the beginning of a cell. $\endgroup$ Commented Jul 16, 2020 at 7:38

On the Mac, Ctrl = will give you the orange box; you are essentially using that to enter natural language input in Mathematica. See guide/WolframAlphaIntegration in the documentation. Any chance you are doing that inadvertently? Once I placed a book that just touched the bottom left of the keyboard and was holding Ctrl down. Or had a second Bluetooth keyboard connected on a side table with papers on top of it.

  • $\begingroup$ Definitely not inadvertently hitting Ctl, either physically or from another device, but this is good to know! $\endgroup$ Commented Jul 15, 2020 at 5:23
  • $\begingroup$ Per your comment elsewhere, = at beginning of cell triggers mode change. See WolframAlpha doc. $\endgroup$ Commented Jul 15, 2020 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.