0
$\begingroup$

I'm trying to use the ANOVA package and have mathematica display the Tukey PostTest, but all I get is this:

ANOVA[Tratamientos, PostTests -> Tukey]

ANOVA::nottest: Tukey is not a valid PostTests entry, and will be ignored. Valid PostTests entries are Bonferroni, Tukey, StudentNewmanKeuls, Duncan, and Dunnett. >>

Any advice? Am I missing something?

Thanks in advance

$\endgroup$
4
  • 1
    $\begingroup$ Hahaha... "Tukey is not a valid PostTests entry, and will be ignored. Valid PostTests entries are Bonferroni, Tukey, ..." $\endgroup$
    – rm -rf
    Apr 2, 2013 at 15:49
  • $\begingroup$ What version are you using? I can't reproduce this back to v.7. $\endgroup$
    – rcollyer
    Apr 2, 2013 at 16:04
  • $\begingroup$ I'm using version 9, also, I'm on linux. $\endgroup$
    – Cobo
    Apr 2, 2013 at 17:40
  • $\begingroup$ Can't reproduce on Win7-64, either v9 or v8. The exact error message is generated if you enter the option value as the string "Tukey" instead of the symbol Tukey. Might that have been the case here? $\endgroup$ Apr 2, 2013 at 19:02

1 Answer 1

1
$\begingroup$

Seems to work here (Mathematica 8.0):

Needs["ANOVA`"]
ANOVA[{{1, 1}, {1, 2}, {2, 15}, {2, 20}}, PostTests -> Tukey]

Mathematica graphics

$\endgroup$
3
  • $\begingroup$ I'm using Mathematica 9, so maybe thats the problem? Also, I'm on linux. $\endgroup$
    – Cobo
    Apr 2, 2013 at 17:40
  • $\begingroup$ @Cobo it works on v. 9 as well (at least on my Mac) $\endgroup$
    – cormullion
    Apr 2, 2013 at 17:43
  • $\begingroup$ @Cobo Also runs here on MMa 9 (Windows 8). Maybe the problem is on the data? Are you sure the data input is in the correct form? $\endgroup$
    – Sos
    Apr 2, 2013 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.