4
$\begingroup$

I've picked up Workbench / DocumentationTools again to add some new tutorials. Everything was going fine until I tried to use the "Link to Tutorial" button in DocTools. Didn't work, and I got some error messages in the console:

StringMatchQ::strse: String or list of strings expected at position 1 in StringMatchQ[$DocumentationDirectory,*/]. >>

StringMatchQ::strse: String or list of strings expected at position 1 in StringMatchQ[$LinkBase,|Whitespace]. >>

The neighboring B-button was even worse. Any ideas on what happened to my previously working setup? I'm using Workbench 10.1.822 and Mathematica 10.0 to make documentation (12.1 is my daily driver) on MacOS 10.14.6.

screenshot showing problem

$\endgroup$
  • $\begingroup$ As far as I know, this is hopelessly broken. If anyone knows what the current state of affairs is, please share. $\endgroup$ – HirenPatel Jun 8 at 7:50
  • $\begingroup$ @HirenPatel Did you encounter the same problem? Because Workbench / DocuTools has been working OK for me until now. $\endgroup$ – Chris K Jun 8 at 14:50
2
$\begingroup$

Figured it out. I needed to hit the Select Paclet Name & Path button and then select the top folder containing my paclet.

screenshot

| improve this answer | |
$\endgroup$
  • $\begingroup$ Happened again (after reinstalling Mathematica, so maybe that's the cause?). Glad to have figured it out before and answered my own question so I could look up how to fix it! $\endgroup$ – Chris K Aug 29 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.