2
$\begingroup$

How can I install Spotlight search and QuickLook on Mac Catalina, for Mathematica version 12.1?

The most important for me is Spotlight search. Without then I can't search for text inside a .nb file, just by file name.

I believe I forgot to do this in my installation, and I don't want to reinstall It.

Some way to execute these files? enter image description here

$\endgroup$
6
  • 1
    $\begingroup$ I don't think they need to be executed ... just put somewhere... let me check. on a mac here: ~/Library/QuickLook/ and probably ~/Library/Spotlight/ $\endgroup$
    – chris
    May 1, 2020 at 15:53
  • $\begingroup$ or /Library/QuickLook/ and /Library/Spotlight/ BUT I have not done it so take it only as a suggestion! $\endgroup$
    – chris
    May 1, 2020 at 15:55
  • 2
    $\begingroup$ I don't think they need to be installed. It should just work as it is. $\endgroup$
    – Szabolcs
    May 1, 2020 at 15:57
  • $\begingroup$ At least for me, it does. I'm on macOS 10.14. I do know that several other apps provide QuickLook generators this way. It is sufficient that the app is present on your computer and that it has been used before. $\endgroup$
    – Szabolcs
    May 1, 2020 at 15:58
  • $\begingroup$ @chris Tks! If you want to answer, I will accept It. You suggestion worked. I just copied the respective files to /Library/QuickLook/ and /Library/Spotlight/ $\endgroup$
    – Murta
    May 1, 2020 at 23:22

1 Answer 1

1
$\begingroup$

For QuickLook to work, the file Wolfram Notebook.qlgenerator needs to be copied to ~/Library/QuickLook/ (user only) or /Library/QuickLook/ (system wide).

For searching into mathematica files, the file Wolfram Notebook.mdimporter needs to be copied to ~/Library/Spotlight (user only) or/Library/Spotlight/` (system wide).

$\endgroup$
7
  • $\begingroup$ This is not correct. These files should be left where they are. The system will pick them up. To see which QuickLook generator the system is actually using, run qlmanage -m plugins | grep wolfram on the command line. You should see the one inside the latest Mathematica app bundle you have installed. $\endgroup$
    – Szabolcs
    May 2, 2020 at 8:41
  • $\begingroup$ as stated above I did not try myself but @Murta said it worked for him. Please delete my post once you converge with him. $\endgroup$
    – chris
    May 2, 2020 at 8:43
  • $\begingroup$ Do you have a later date on 10.3 than on 12.0? Or do you have .nb files set to open with 10.3 by default? $\endgroup$
    – Szabolcs
    May 2, 2020 at 8:55
  • $\begingroup$ No, I meant the date on the .app. $\endgroup$
    – Szabolcs
    May 2, 2020 at 9:19
  • $\begingroup$ @Szabolcs The same. nb files open with 12.0 $\endgroup$
    – chris
    May 2, 2020 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.