7
$\begingroup$

I recently upgraded to version 12.1. When running from terminal, program crashes, with the following error:

Qt issued a fatal error: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: linuxfb, minimal, offscreen, vnc, xcb.

Qt tried to load plugins from: /usr/local/Wolfram/Mathematica/12.1/SystemFiles/Libraries/Linux-x86-64/Qt/plugins /usr/local/Wolfram/Mathematica/12.1/SystemFiles/FrontEnd/Binaries/Linux-x86-64

Mathematica was installed in /usr/local/Wolfram/Mathematica/12.1 /usr/local/bin/mathematica: line 138: 20411 Aborted                 (core dumped) "${MathematicaFE}" ${MESA_FLAG} -topDirectory "${TopDirectory}" "$@"

No idea how to proceed. Version 12.0 did not have any problems. Using Fedora Linux 31.

$\endgroup$
4
  • 1
    $\begingroup$ You should contact tech support for this. $\endgroup$
    – Jason B.
    Commented Apr 27, 2020 at 17:01
  • 1
    $\begingroup$ I use the same linux distribution and both versions work fine. $\endgroup$ Commented Apr 27, 2020 at 17:26
  • $\begingroup$ Do you use Matlab R2019b/R2020a? I only encountered this failure when Matlab is in the path. In my case, the QT-library is hijacked by Matlab. Removing Matlab from the path, and Mathematica starts in the Frontend mode without problems. The solution below solves now the problem of a data transfer while relying on MATLink. $\endgroup$ Commented Aug 27, 2020 at 10:07
  • $\begingroup$ Nope, no Matlab in my system. $\endgroup$
    – Stilgar
    Commented Aug 28, 2020 at 14:58

2 Answers 2

6
$\begingroup$

As suggested in the comments, I got in touch with Wolfram support. After a couple of iterations, we found out that the problem was solved by adding a new environment variable:

export USE_WOLFRAM_LD_LIBRARY_PATH=1

After this, I could run version 12.1 without any issues.

$\endgroup$
0
$\begingroup$

Stilgar's solution works. However, it is also recommended to install the missing Qt5 libraries and other dependencies as mentioned here:

https://support.wolfram.com/59044

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.