2
$\begingroup$

I've implemented the code in the top answer of this question on the Plateau problem in differential geometry, and it works with the example shown in Example 1, so there is nothing wrong with the code. However, when I try to do this with my own mesh region, the text for variable names for the mesh remains blue, no matter what I do, indicating Mathematica does not seem to understand that I have defined a mesh region by that name.

In particular, my goal is to create images for the minimal surface spanning a particular quadrilateral. My meshregion is the following:

R = MeshRegion[{{0,1,0},{1,0,0},{1,1,0},{1,0,1}},Polygon[{{1,2,3},{2,3,4}}]]

I've also tried other variations on this idea, like making a polygonal Region in the same way, and then using DiscretizeRegion. This doesn't seem to help. If it isn't too much to ask, can somebody either tell me what it is about this code that Mathematica won't recognize, or take a look at the code in that question and enlighten me as to how to make it work on such a region? I didn't want to just leave a comment on such an old thread, since it's customary on MSE to ask new questions when one encounters a problem.

Edit: After talking with Henrik, we came to the conclusion that it's definitely not a problem with the code, and something with Mathematica for me. I've added a tag to indicate that the problem is not geometrical, nor with the code, but with the kernel, somehow.

Update: My kernel started crashing. I have no idea why. After said crash, the notebook just works. Bizarre.

$\endgroup$

1 Answer 1

3
$\begingroup$

I am not sure what you mean. When you apply DiscretizeRegion to a triangle surface, it will split triangles only specify a refinement. So maybe this works? (It works for me...)

R = DiscretizeRegion[
  MeshRegion[{{0, 1, 0}, {1, 0, 0}, {1, 1, 0}, {1, 0, 1}}, 
   Polygon[{{1, 2, 3}, {2, 3, 4}}]],
  MaxCellMeasure -> (1 -> 0.01)
  ]

And now (with the function areaGradientDescent from my other post):

areaGradientDescent[R, 1., 16., True]

enter image description here

$\endgroup$
10
  • $\begingroup$ It's clearly a local problem. I took your code and tried it verbatim (even though I have essentially tried this variation already), and it still has the 'R' in blue. So Mathematica is just refusing to see what's going on here. Also, thanks for your answer to both the first question and for helping me out with your code! $\endgroup$ Mar 25, 2020 at 16:58
  • 1
    $\begingroup$ Still blue. It seems to have nothing to do with your code, and something to do with my kernel? I tried resetting the kernel, and that did not make any difference though. $\endgroup$ Mar 25, 2020 at 17:26
  • 1
    $\begingroup$ At the end of the discussion, we didn't know what the issue was, so the question is still pretty much open. $\endgroup$ Mar 25, 2020 at 18:15
  • 1
    $\begingroup$ I accepted your answer because after some even more bizarre, behavior, the suggestion in your comment worked. I have no idea why. $\endgroup$ Mar 25, 2020 at 18:24
  • 1
    $\begingroup$ Uhm. Okay, great! $\endgroup$ Mar 25, 2020 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.