9
$\begingroup$

Today I just upgrade my Mathematica to 12.1 under Ubuntu 19.04.

Everything works fine but the font size is too small. As a result, I set the zoom level to 150%. Even though the font in the editor zone is big enough, the font size in the Context-Sensitive Autocompletion pop-up window is still too small to read.

I wonder how to increase the font size in the Context-Sensitive Autocompletion.

Thank you.

P.S. Resolution of my monitor is 4k Ultra HD.

$\endgroup$
  • $\begingroup$ related: 189467 $\endgroup$ – Kuba Mar 19 at 10:27
  • $\begingroup$ Before modding anything, I would try setting ScreenResolutionCompatibilityMode->False and see if that helps. You can find it in the Options Inspector under System Configuration. If that doesn't help, send something to tech support with the output from SystemInformation[] attached. $\endgroup$ – ihojnicki Mar 19 at 12:21
  • $\begingroup$ @Kuba I edited Core.nb as Cell[StyleData["CodeAssistCharCompletion", StyleDefinitions -> StyleData[ "CodeAssistCompletion"]], **FontSize->24**, ...] . But the software startup failed. $\endgroup$ – PureLine Mar 19 at 14:03
  • $\begingroup$ @ihojnicki This solution does not work. $\endgroup$ – PureLine Mar 19 at 14:04
  • $\begingroup$ @Kuba I also found a webpage mathematica.stackexchange.com/questions/101641/… . And I have work it out. The problem is I can understand how you edit the stylesheet in this webpage. $\endgroup$ – PureLine Mar 19 at 14:39
7
$\begingroup$

Suggested by @ihojnicki, another solution is:

  1. create a file named ~/.Mathematica/FrontEnd/frontend.css;

  2. append the following configuration to frontend.css:

    * { font-size:16pt; font-family:"Griffy"; }
    
  3. done.
| improve this answer | |
$\endgroup$
  • $\begingroup$ It does not work for me. Maybe add something else? $\endgroup$ – nail May 16 at 15:56
  • $\begingroup$ @nail Please try my other solutions within this post. All of them work for me. $\endgroup$ – PureLine Jun 1 at 2:37
  • $\begingroup$ The QT_SCALE_FACTOR=1.5 Mathematica is working for me, only. But it is very inconvenient because this option enlarge the window of the Mathematica also. I really very surprised why the solution with frontend.css is working for you but not for me. $\endgroup$ – nail Jun 2 at 11:26
  • $\begingroup$ @nail my platform is Mathematica 12.1 under Ubuntu 19.04. $\endgroup$ – PureLine Jun 5 at 12:07
  • $\begingroup$ I use Mathematica 12.1 under Linux MInt 18 (based on ubuntu 18). I'm tired of fighting this problem and came back to Mathematica 11.1 where changing the fonts and font size is very simple. $\endgroup$ – nail Jun 6 at 16:04
5
$\begingroup$

Inspired by the solution from Font size for help drop down menu in input cell, my solution is as followed:

  1. Go to menu Format / Edit Stylesheet. this will open the style configuration similar as the left of the following image.

  2. Open Core.nb in $InstallationDirectory/SystemFiles/FrontEnd/Stylesheets. This doc looks as the right of the following image.

  3. Copy the cells "CodeAssistCompletion" and "CodeAssistCompletionHighlight" from Core.nb to the opened window in 1., and format these two cells by configuring menu -> Fromat -> Size.

Done. This configuration increases the font size only for this notebook, not for global setting.

I am still looking forward to a permanent global setting.

enter image description here

| improve this answer | |
$\endgroup$
  • 4
    $\begingroup$ I think you would be better off creating a custom Qt stylesheet for the FrontEnd to use. ~/.Mathematica/FrontEnd/frontend.css. That should also make the font size of the menus larger as well. Which are probably small too. $\endgroup$ – ihojnicki Mar 19 at 17:01
  • $\begingroup$ @ihojnicki very cool to know that exists $\endgroup$ – b3m2a1 Mar 19 at 19:56
  • $\begingroup$ @ihojnicki I have given up to customize the GUI interface. To learn Qt stylesheet is too much work. 囧rz.. $\endgroup$ – PureLine Mar 22 at 13:24
  • 3
    $\begingroup$ @PureLine I wouldn't have expected it to be more than... * { font-size:16pt; font-family:"Griffy"; } $\endgroup$ – ihojnicki Mar 22 at 15:31
  • 1
    $\begingroup$ @ihojnicki Fancy! It works. $\endgroup$ – PureLine Mar 22 at 15:53
4
$\begingroup$

Launch Mathematica from the terminal in Ubuntu 19.04 with the following command:

 QT_SCALE_FACTOR=1.5 Mathematica

The font size in the Context-Sensitive Autocompletion increases, except for the font in the pop-up window blurs.

| improve this answer | |
$\endgroup$
0
$\begingroup$
  1. Go to Format / Option Inspector
  2. Show Option Values: change from Selection to Global Preferences
  3. Go to Global Options / System Configurations / ScreenResolutionCompatibilityMode - False
  4. Restart Mathematica
| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.