0
$\begingroup$

I have recently updated to Mma 12 (from Mma 9). I input: GraphData[{"Path", 5}] and I get:

{"Biconnected", "Connected", "Cyclic", "Eulerian", "HamiltonConnected", "Hamiltonian", "LCF", "Quartic", "Regular", "Traceable", "WeaklyRegular"}

Is this a bug? Is there a work around?

$\endgroup$
  • 1
    $\begingroup$ Please be a bit more specific than "I get nonsense", then we can maybe get to the root of the problem. That command returns the expected $P_5$ for me in version 12.0.0. $\endgroup$ – Szabolcs Feb 14 at 14:53
  • $\begingroup$ OK Thanks I edited my question. $\endgroup$ – geoffrey Feb 14 at 15:46
  • 1
    $\begingroup$ When I run the command GraphData[{"Path", 5}] I get 5 vertices in a line connected by straight edges. However, it did have to connect to the Wolfram Servers before it ran. I'm not very sure, but my guess would be it has something to do with a bad Paclet. The function itself doesn't appear bugged since it runs on other computers, but it might be that your copy of MMA hasn't updated that function or downloaded all the data it needs to run. I would try looking at the answers to questions on how to clear and re-download Wolfram paclets. $\endgroup$ – MassDefect Feb 14 at 16:41
  • $\begingroup$ Try this: 1) make sure you have an internet connection 2) start Mathematica and run PacletUninstall /@ PacletFind["GraphData*"] 3) restart Mathematica 4) try again and let it re-download the data $\endgroup$ – Szabolcs Feb 14 at 16:54
  • $\begingroup$ OK Thanks. I will try this. $\endgroup$ – geoffrey Feb 14 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.